SMSSP3_OM07_MPGD.cover

Guia do Pacote de Gerenciamento do Microsoft Systems Management Server 2003 Service Pack 3 para Operations Manager 2007

Microsoft Corporation

Publicado em: maio de 2007

Comentários

Envie sugestões e comentários sobre este documento para smsdocs@microsoft.com. Inclua o nome do guia do Pacote de Gerenciamento em seus comentários.


SMSSP3_OM2007_MPGuide.copy

Information in this document, including URL and other Internet Web site references, is subject to change without notice. Unless otherwise noted, the companies, organizations, products, domain names, e-mail addresses, logos, people, places, and events depicted in examples herein are fictitious. No association with any real company, organization, product, domain name, e-mail address, logo, person, place, or event is intended or should be inferred. Complying with all applicable copyright laws is the responsibility of the user. Without limiting the rights under copyright, no part of this document may be reproduced, stored in or introduced into a retrieval system, or transmitted in any form or by any means (electronic, mechanical, photocopying, recording, or otherwise), or for any purpose, without the express written permission of Microsoft Corporation.

Microsoft may have patents, patent applications, trademarks, copyrights, or other intellectual property rights covering subject matter in this document. Except as expressly provided in any written license agreement from Microsoft, the furnishing of this document does not give you any license to these patents, trademarks, copyrights, or other intellectual property.

© 2007 Microsoft Corporation. All rights reserved.

Microsoft, MS-DOS, Windows, Windows Server, and Windows Vista are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

All other trademarks are property of their respective owners.


Pacote de Gerenciamento do Microsoft System Management Server 2003 para o Operations Manager 2007

Bem-vindo ao Pacote de Gerenciamento do Microsoft® System Management Server 2003 para Operations Manager 2007. O pacote de gerenciamento fornece recursos novos e aprimorados para o monitoramento do SMS 2003.

Recursos do Pacote de Gerenciamento

Para obter mais informações sobre recursos, consulte os tópicos a seguir.

Visão geral do Pacote de Gerenciamento do System Management Server 2003

  • Cenários de monitoramento do Pacote de Gerenciamento
  • Implantando o Pacote de Gerenciamento do SMS 2003
  • Executando tarefas de operações do Pacote de Gerenciamento do SMS 2003
  • Solução de problemas do Pacote de Gerenciamento do SMS 2003
  • Referência do Pacote de Gerenciamento do Microsoft System Management Server 2003


Visão geral do Pacote de Gerenciamento do System Management Server 2003
Consulte também

Este guia o familiarizará com as informações técnicas e de implantação do Pacote de Gerenciamento do SMS 2003. Com essas informações, você pode planejar a implantação do Pacote de Gerenciamento, entender os recursos que ele oferece e aprender como usar esses recursos para beneficiar sua organização de TI.

O Pacote de Gerenciamento do System Center Operations Manager 2007 para SMS oferece recursos aprimorados para o monitoramento do SMS 2003, incluindo:

  • Monitoramento do início e término de todos os serviços do SMS 2003, incluindo serviços dependentes críticos, como a Instrumentação de Gerenciamento do Windows (WMI), os Serviços de Informações da Internet (IIS), o Serviço de Transferência Inteligente em Segundo Plano (BITS) e o Microsoft SQL Server™.
  • Alerta do administrador do SMS com relação a mensagens críticas de status do SMS.
  • Monitoramento de registros posteriores de registros dos dados de descoberta (DDRs), inventário de software, inventário de hardware, mensagens de status e medição de software nos servidores de área principal e nos pontos de gerenciamentos.
  • Monitoramento de uso de recursos do sistema.
  • Monitoramento de taxas de processamento.
  • Monitoramento das tendências de desempenho de vários contadores de desempenho do SMS usando modos de exibição e relatórios.
  • Conteúdo da base de dados do produto para todos os alertas e regras de processamento.
  • Detecção de todos os computadores e grupos de computadores do SMS 2003.
  • Modos de exibição.
  • Relatórios que exibem o desempenho, a disponibilidade e a configuração de pontos de gerenciamento e grupos de servidores do SMS 2003. Estão incluídos relatórios vinculados que fornecem relatórios avançados do Systems Center Operations Manager 2007 com relação a tendências de desempenho, configuração e disponibilidade.
  • Monitoramento do Feature Pack do Gerenciamento de Dispositivos.
  • Tarefas para executar os aplicativos do SMS Administrator Console.
  • Modo de exibição de estado com a integridade de todas as funções de servidor do SMS e do SMS Advanced Client.
  • Descoberta de Serviços de informações importantes do servidor do SMS e do cliente do SMS.
  • Supressão de alertas de Serviço Indisponível decorrentes da execução do Backup de Site do SMS.
  • Diagrama de topologia da hierarquia do site do SMS (SMS 2003 service pack 3 necessário).
  • Alertas configuráveis do SMS 2003 Service Pack 3 (SP3) na falha da execução de programas distribuídos por meio das propriedades do programa SMS.

Para obter mais informações sobre recursos e cenários de monitoramento, consulte Cenários de monitoramento do Pacote de Gerenciamento. O Pacote de Gerenciamento do SMS 2003 não foi criado para:

  • Monitorar o SMS 1.2, SMS 2.0, SMS 2003 SP2.
  • Monitorar ambientes do SMS mistos. Os ambientes mistos possuem instalações do SMS 1.2, do SMS 2.0 e do SMS 2003 sendo executadas lado a lado.
  • Monitoramento limitado de computadores apenas do cliente do SMS que executam o SMS Advanced Client.
  • Fornecer uma solução de monitoramento pronta que gerencie qualquer instalação do SMS 2003 sem modificações. Os limites das regras são diferentes para cada instalação do SMS 2003 e os clientes devem personalizar suas regras.

Nesta seção

Novidades desta atualização

Conhecimento recomendado

Configuração suportada do SMS

Consulte também

Cenários de monitoramento do Pacote de Gerenciamento
Implantando o Pacote de Gerenciamento do SMS 2003

Outros recursos

Executando tarefas de operações do Pacote de Gerenciamento do SMS 2003
Solução de problemas do Pacote de Gerenciamento do SMS 2003
Referência do Pacote de Gerenciamento do Microsoft System Management Server 2003


Novidades desta atualização

O Pacote de Gerenciamento do System Management Server 2003 para Operations Manager 2007 inclui o modo de manutenção. O modo de manutenção suprime os alertas do Operations Manager enviados por computadores cliente enquanto o software do SMS está em execução no computador cliente.

Atualizar o modo de manutenção do SMS 2003

Quando o System Management Server 2003 distribui software para os computadores, freqüentemente é necessário desabilitar temporariamente os alertas baseados em regras do Operations Manager gerados pelo computador de destino. Por exemplo, a implantação de hotfixes e patches de segurança em servidores pode exigir o desligamento de threads e serviços. Se os threads ou serviços nesses servidores forem monitorados por um pacote de gerenciamento, vários alertas do Operations Manager poderão ser gerados, sobrecarregando o servidor do Operations Manager.

A caixa de seleção Disable MOM alerts while this program runs suspende os alertas do Operations Manager até que o software distribuído tenha concluído. O administrador do SMS pode definir esta caixa de seleção nas propriedades do programa do pacote do SMS. A configuração dessa opção suprime os alertas do Operations Manager para todos os pacotes de gerenciamento que têm o computador cliente como destino, enquanto o computador cliente estiver executando esse programa.

Se essa opção estiver selecionada, quando o anúncio for executado na máquina de destino, o agente do Operations Manager será colocado no modo de manutenção. O agente do SMS também fornece uma configuração de tempo limite para o agente do Operations Manager. Depois que o anúncio é executado no computador de destino, o agente do cliente do SMS continua o monitoramento do agente do Operations Manager no computador. Depois disso, todos os eventos que disparam alertas serão relatados normalmente.

Se a distribuição de software falhar ao ser executada no computador de destino, as seguintes ações ocorrerão:

  • Se a distribuição retornar um código de falha, o agente do SMS removerá o agente do Operations Manager do modo de manutenção, como se a distribuição tivesse sido bem-sucedida.
  • Se a distribuição falhar inesperadamente e o agente do SMS não receber um código de falha em um tempo limite predefinido, o agente do Operations Manager sairá do modo de manutenção.

Habilitar o modo de manutenção para um programa do SMS 2003

Use o seguinte procedimento para habilitar o modo de manutenção em computadores cliente enquanto os programas do SMS 2003 estão em execução.

Para habilitar o modo de manutenção para um programa do SMS 2003

  1. No console do Systems Management Server, navegue até Systems Management Server / Site Database - <nome do servidor do site> / Pacotes.

  2. No painel de detalhes, clique com o botão direito do mouse no Programa e clique em Propriedades.

  3. Na caixa de diálogo Propriedades do Programa, clique na guia MOM.

  4. Selecione Disable MOM alerts while this program runs e clique em OK.

Depois de habilitar o modo de manutenção para o programa do SMS 2003, o computador cliente entrará no modo de manutenção, enquanto o pacote do SMS 2003 é distribuído e executado.

Observação
O tempo limite do modo de manutenção é definido na caixa de diálogo Propriedades do Programa, na guia Requirements, com a propriedade Maximum allowed runtime selecionada.

Topologia do site do SMS 2003

Os diagramas hierárquicos do SMS 2003 no Microsoft Operations Manager (MOM) 2005 foram substituídos por uma hierarquia do site do SMS 2003. O modo de exibição hierárquico exibe agora funções de servidor no modo de exibição de topologia.

Scripts de configuração removidos

Como o SMS 2003 SP2 ou posteriores é a versão recomendada do SMS, os scripts de configuração foram removidos.

Relatórios do SMS 2003

O SMS 2003 contém novos relatórios que enfocam contadores de desempenho por função do sistema do site e contadores de desempenho por contador de processamento de objetos, como contadores relacionados aos DDRs. Para obter mais informações sobre os novos relatórios, consulte Relatórios do SMS 2003.

Consulte também

Relatórios do SMS 2003
Scripts do SMS 2003


Conhecimento recomendado

Para implantar e operar o Pacote de Gerenciamento do SMS 2003, recomenda-se que você tenha os conhecimentos e qualificações a seguir:

  • Conhecimento prático dos recursos de monitoramento do Operations Manager 2007. Para obter mais informações sobre o Operations Manager 2007, consulte a página da Web do Operations Manager 2007 (http://go.microsoft.com/fwlink/?LinkID=83259).
  • Noções básicas da arquitetura de design do Operations Manager 2007 e da arquitetura de design implantada na sua organização.
  • Familiaridade com o processo recomendado de implantação de Pacotes de Gerenciamento, como descrito no Guia de Implantação do System Center Operations Manager 2007.
  • Conhecimento prático dos conceitos e da terminologia do SMS. Para obter mais informações sobre o SMS 2003, consulte a página da Web da documentação do produto SMS 2003, (http://go.microsoft.com/fwlink/?linkid=9502).

Consulte também

Cenários de monitoramento do Pacote de Gerenciamento
Implantando o Pacote de Gerenciamento do SMS 2003

Outros recursos

Executando tarefas de operações do Pacote de Gerenciamento do SMS 2003


Configuração suportada do SMS

Os requisitos do SMS 2003 e do Systems Center Operations Manager 2007 estão documentados em seus respectivos guias de implantação. O Pacote de Gerenciamento do SMS 2003 monitora o SMS 2003. O SMS 2003 SP2 e versões posteriores são recomendados. A execução do SMS 2003 SP1 exigirá a execução de um script de carimbo.

A habilitação do modo de manutenção durante a distribuição de software e o mapeamento da topologia com o Operations Manager 2007 exigem o SMS 2003 SP3 ou posterior.

Este Pacote de Gerenciamento do SMS 2003 não monitora o SMS 1.2 , o SMS 2.0 ou o Gerenciador de configurações 2007.

Consulte também

Outros recursos

Referência do Pacote de Gerenciamento do Microsoft System Management Server 2003
Solução de problemas do Pacote de Gerenciamento do SMS 2003


Cenários de monitoramento do Pacote de Gerenciamento

O Microsoft® Systems Management Server (SMS) 2003 fornece recursos novos e aprimorados para o monitoramento do SMS 2003. As seções a seguir descrevem os principais cenários para os quais o Pacote de Gerenciamento do SMS 2003 dá suporte, juntamente com uma descrição de seus recursos.

Disponibilidade de serviço

Descoberta de serviço

Monitoramento da disponibilidade

Monitoramento de estado

Suporte ao monitoramento sem agente

Monitoramento do limite do desempenho

Monitoramento do desempenho

Monitoramento de mensagens de status críticas do SMS

monitoramento do sistema do site

Monitoramento do despejo de memória do Executivo

Monitoramento de registro posterior

Monitoramento da integridade geral

Monitoramento do gerenciamento de patch do SMS

Monitoramento de backup do site do SMS

Conteúdo de conhecimento do produto para todos os alertas

Grupos de computadores para todas as funções de cliente e servidor do SMS 2003

Monitoramento expandido

Status da execução de programa de distribuição de software

Disponibilidade de serviço

A disponibilidade de serviços monitora a disponibilidade dos serviços do SMS usando o recurso Disponibilidade de Serviços do System Center Operations Manager 2007 e os eventos do Gerenciador de Controle de Serviços no Log do sistema de eventos do NT. O monitoramento de disponibilidade de serviços gera:

  • Um alerta quando os serviços baseados no SMS param nos sistemas do site do SMS.
  • Um alerta quando um serviço crítico dependente do SMS, como a Instrumentação de Gerenciamento do Windows (WMI), pára ou falha ao iniciar nos sistemas do site do SMS.
  • Um alerta quando outros serviços dependentes do SMS, como o Microsoft SQL Server™, os Serviços de Informações da Internet (IIS) e o Serviço de Transferência Inteligente em Segundo Plano (BITS), param ou falham ao iniciar nos sistemas do site do SMS.
  • Um alerta quando o serviço Backup de site do SMS é iniciado e parado, de forma que você possa monitorar as durações do backup e correlacionar eventos de parada de outros serviços do SMS ao Backup de site do SMS.

Descoberta de serviço

A descoberta de serviços é o processo de descoberta de dados, funções de servidor e componentes nos computadores gerenciados. A descoberta de serviços retorna informações sobre servidores SMS e clientes avançados do SMS. Ele também dá suporte à apresentação das funções de servidores e clientes do SMS no modo de exibição de monitoramento de estado.

Os dados de descoberta de serviços específicos do servidor são coletados e começam a ser exibidos no Console de Operações do System Center após a implantação do Pacote de Gerenciamento. Os recursos que exigem a identificação de funções, grupos de computadores e computadores de destino para tarefas específicas não estarão disponíveis até que os dados de descoberta de serviços sejam coletados pela primeira vez.

O Pacote de Gerenciamento do SMS 2003 usa as seguintes regras de processamento de eventos para iniciar os scripts de descoberta de serviços:

  • Clientes do SMS\Clientes SMS - Avançado\Descoberta de serviços do SMS 2003
  • Servidores do SMS\Servidores do SMS - Comum\Descoberta de serviços do SMS 2003

Por padrão, os scripts usam um provedor de tempo limite assíncrono para coletar dados de descoberta de serviços uma vez a cada 24 horas. O provedor também executa o seguinte:

  • Implantação do Pacote de Gerenciamento
  • Alterações de configuração do Pacote de Gerenciamento
  • Início e parada do agente do Operations Manager 2007

Monitoramento da disponibilidade

Nesta versão do Pacote de Gerenciamento do SMS, são fornecidos três relatórios de disponibilidade: Relatório de disponibilidade de servidores do SMS 2003, Relatório de disponibilidade de pontos de gerenciamento do SMS 2003 e Relatório de disponibilidade de servidores do site do SMS 2003.

O relatório de Disponibilidade de pontos de gerenciamento é um relatório de disponibilidade baseado na integridade do componente. A disponibilidade de pontos de gerenciamento se baseia em um novo algoritmo, em novas regras e no script SMS 2003 Monitor Management Point Availability.

Todos os relatórios, incluindo os novos relatórios referidos nesta seção, são executados com relação ao banco de dados do Operations Manager, o que permite especificar durações mais longas para os relatórios que com o script anterior, que criava e armazenava procedimentos somente no banco de dados do Operations Manager.

Para obter mais informações sobre a disponibilidade de servidores, consulte Scripts do SMS 2003 e Relatórios do SMS 2003.

Monitoramento de estado

O monitoramento de estado fornece uma representação gráfica da integridade de todos os servidores ou dos servidores delimitados para grupos de computadores específicos. O Pacote de Gerenciamento dá suporte a este recurso com uma lista específica de grupos de computadores. Os componentes e funções de servidor são gerenciados por meio da descoberta de serviços e a integridade dos componentes é gerenciada por um conjunto de regras com relação à disponibilidade de serviços, limites de desempenho e a integridade de pontos de gerenciamento.

A tabela abaixo mostra estados de integridade monitorados por componentes do SMS identificados por cores.

Monitoramento de estado de servidores do SMS

Componente do SMS | Verde (Bem-sucedido) | Amarelo (Aviso) | Vermelho (Crítico)
Servidor do site (SS) | Sim | Sim | Sim
Ponto de gerenciamento (MP) | Sim | Sim | Sim
Banco de dados do site (DB) | Sim | Sim | Sim
Ponto de distribuição (DP) | Sim |  |
Ponto de localizador do servidor (SLP) | Sim |  | Sim
Remetente | Sim |  | Sim
Ponto de relatório (RP) | Sim |  | Sim
Provedor | Sim |  | Sim
Ponto de acesso do cliente (CAP) | Sim |  | Sim
Desempenho | Sim | Sim | Sim
Observação
Não existem regras de monitoramento que irão alterar o estado do componente de ponto de distribuição; assim, se o componente estiver presente, ele será relatado apenas em um estado verde. Se um componente de ponto de distribuição não estiver presente, a integridade do estado não será representada no console.

Monitoramento de estado do cliente do SMS

Componente do SMS | Verde (Bem-sucedido) | Amarelo (Aviso) | Vermelho (Crítico)
Serviço de cliente | Sim |  | Sim

Suporte ao monitoramento sem agente

O Pacote de Gerenciamento do SMS 2003 dá suporte ao monitoramento em computadores gerenciados sem agente, exceto pelos recursos listados a seguir:

  • Monitoramento de mensagens críticas de status do SMS
  • Monitoramento de status do sistema do site
  • Topologia

Os scripts que dão suporte aos recursos acima são os seguintes:

  • Monitoramento de Mensagens de Status do SMS 2003
  • Monitoramento do Resumidor do Sistema do Site do SMS 2003
  • SMS 2003 Server Topology: Discovery

Esses scripts devem ser executados localmente com relação ao Provedor do SMS para acessarem o namespace do SMS. Se os scripts não conseguirem localizar o namespace do SMS, ocorrerá um evento de erro de script.

Monitoramento do limite do desempenho

Os níveis de desempenho reduzidos podem criar atrasos e afetar os contratos de nível de serviço (SLAs) do cliente em termos de tempo, desempenho e precisão dos dados. É importante detectar e resolver os problemas críticos de desempenho na infra-estrutura do SMS. O monitoramento de limites de desempenho gera um alerta quando:

  • Métricas gerais de integridade de todo o computador relacionados à CPU, ao arquivo de paginação e à memória em sistemas do site do SMS excedem determinados limites.
  • O número total de conexões de usuários do Microsoft SQL Server™ excede um limite.
  • O número total de arquivos do SMS [como trabalhos do agendador, solicitações de envio, registros de medição de software, registros dos dados de descoberta (DDRs) e registro dos inventários de software e hardware] excede determinados limites nas caixas de entrada do servidor do site do SMS.
  • O número total de mensagens do SMS relacionadas a mensagens de status, DDRs, inventários de software e de hardware nas filas de mensagens do ponto de gerenciamento do SMS excede determinados limites.

Monitoramento do desempenho

O monitoramento de desempenho permite observar tendências em registros posteriores, taxas de processamento e contagens totais dos principais objetos do SMS para ajudar a identificar e resolver problemas de forma proativa. A tendência de desempenho monitora as seguintes tendências graficamente, usando os Modos de exibição e Relatórios do Operations Manager 2007:

  • Arquivos de registro posterior relacionados a trabalhos do agendador, solicitações de envio, registros de medição de software, DDRs, inventários de hardware e de software, e mensagens de status em servidores do site do SMS.
  • Taxas de processamento de trabalhos do agendador, solicitações de envio, registros de medição de software, DDRs, inventários de hardware e de software, e mensagens de status em servidores do site do SMS.
  • Número total de trabalhos do agendador, solicitações de envio, registros de medição de software, DDRs, inventários de hardware e de software, e mensagens de status em servidores do site do SMS.
  • Registros posteriores de mensagens relacionadas a DDRs, inventário de hardware e de software, medição de software, mensagens de status e outros objetos do SMS nas filas de mensagens do servidor do ponto de gerenciamento do SMS.
  • Taxas de processamento de DDRs, inventário de hardware e de software, medição de software, mensagens de status e outros objetos do SMS nas filas de mensagens do servidor do ponto de gerenciamento do SMS.
  • Totais de DDRs, inventário de hardware e de software, retransmissões e mensagens de status nas filas de mensagens do servidor do ponto de gerenciamento do SMS.
  • Número total de conexões de usuários do SQL Server nos servidores de banco de dados do site do SMS.
  • Métricas de integridade de todo o computador relacionados à CPU, ao arquivo de paginação e à memória em sistemas do site do SMS.
  • Número total de threads do SMS Executive em execução.
  • Taxa de solicitações de extensão do ISAPI para o IIS.

Monitoramento de mensagens de status críticas do SMS

A infra-estrutura do SMS gera mensagens de status do SMS. É importante identificar as mensagens críticas de status do SMS relacionadas ao servidor e resolvê-las oportunamente. Normalmente, elas indicam problemas de disponibilidade, desempenho, configuração e da integridade geral da infra-estrutura do SMS.

O monitoramento de mensagens críticas de status do SMS gera um alerta quando mensagens de status críticas para a integridade da função do site do SMS são detectadas (como instalação de componentes, conectividade do banco de dados e conectividade do site). O banco de dados do site do SMS é verificado quanto a mensagens críticas de status do SMS a cada meia hora.

Monitoramento do status do sistema do site

O SMS monitora a integridade básica de seus sistemas de sites periodicamente por meio do resumidor de status do sistema do site, que faz a sondagem dos sistemas do site do SMS uma vez a cada hora, na hora cheia. Para tirar proveito deste recurso, é necessário agir rapidamente sobre esse status para evitar a degradação da funcionalidade do SMS. O monitoramento de status do sistema do site permite monitorar e gerenciar um alerta quando é detectado um status do resumidor do sistema do site do SMS crítico à integridade do sistema do site do SMS. Algumas das mensagens de status monitoradas incluem a inatividade de um sistema do site do SMS, a falta de espaço para banco de dados ou log em um servidor que executa o SQL Server e a falta de espaço físico em disco nos sistemas do site do SMS.

Monitoramento do despejo de memória do Executivo

As falhas do serviço SMS Executive afetam a disponibilidade do SMS, sendo importante saber quando ocorrem despejos de memória e investigar suas causas. Quando um serviço SMS Executive falha, ele cria um subdiretório de log de despejo de memória no diretório SMS\Logs\CrashDumps. A criação desse subdiretório é monitorada, sendo gerado um alerta para qualquer função de servidor do SMS que dependa do serviço SMS Executive.

O script SMS 2003 Monitor SMS Executive Crash Dumps relata apenas o despejo de memória mais recente. Isso se aplica independentemente do tempo decorrido desde o último despejo de memória, desde a primeira vez em que o script é executado até qualquer momento em que o SMS Executive seja desinstalado e reinstalado posteriormente.

As regras relacionadas fazem parte do grupo de regras Servidores do Microsoft SMS 2003 baseados no SMS Executive:

  • Despejos de memória do SMS 2003: monitorando o SMS Executive

Despejos de memória do SMS 2003: monitorando o SMS Executive inicia o script usando o provedor de eventos com tempo limite SMS 2003 Schedule every 60 minutes synchronize at 00:10. Informações resumidas são fornecidas na página de propriedades de Conhecimento da regra.

  • Despejos de memória do SMS 2003: monitorando erros de script do SMS Executive

Despejos de memória do SMS 2003: monitorando erros de script do SMS Executive monitora e emite alertas sobre eventos de erros de script que podem ser gerados. Só há um evento de erro de script, número 1102, que informa sobre todos os erros de script. Informações sobre resolução do alerta são fornecidas na página de propriedades de Conhecimento da regra.

  • Despejos de memória do SMS 2003: falha do SMS Executive

Despejos de memória do SMS 2003: falha do SMS Executive monitora e emite alertas sobre o evento de despejo de memória. Informações sobre resolução do alerta são fornecidas na página de propriedades de Conhecimento da regra.

Monitoramento de registro posterior

Os registros posteriores criam atrasos e afetam os contratos de nível de serviço (SLAs) do cliente em termos de tempo, desempenho e precisão dos dados. É importante detectar e resolver os problemas críticos de desempenho na infra-estrutura do SMS imediatamente. Um alerta é gerado quando um registro posterior está acima de um limite por um determinado período com relação ao:

  • Número total de arquivos do SMS, como trabalhos do agendador, solicitações de envio, registros de medição de software, registros dos dados de descoberta (DDRs) e registro dos inventários de software e hardware nas caixas de entrada do servidor do site do SMS.
  • Número total de objetos do SMS [como trabalhos do agendador, solicitações de envio, registros de medição de software, registros dos dados de descoberta (DDRs) e registro dos inventários de software e hardware] nas filas do servidor do site do SMS.

O número total de mensagens do SMS relacionadas a mensagens de status, DDRs, inventários de software e de hardware nas filas de mensagens do ponto de gerenciamento do SMS.

Monitoramento da integridade geral

O monitoramento de integridade geral emite um alerta quando uma métrica de integridade em um servidor do SMS está acima de um determinado limite por um período. O monitoramento de integridade geral verifica as seguintes métricas:

  • Tempo de processador em 95% por três horas
    • Smsexec
    • Ccmexec
    • Total
  • Uso do arquivo de paginação em 98% por três horas

Monitoramento do gerenciamento de patch do SMS

Os Administradores do SMS dependem dos recursos de gerenciamento de patches do SMS para manter os computadores do cliente e do servidor em suas empresas com as atualizações de segurança mais recentes. O monitoramento do gerenciamento de patches detecta falhas no processamento e na configuração do gerenciamento de patches do SMS. O monitoramento do gerenciamento de patches do SMS gera um alerta quando:

  • O processo de sincronização do gerenciamento de patches do SMS falha.
  • O processo de gerenciamento de patches do SMS falha ao atualizar os pontos de distribuição do SMS.

Monitoramento de backup do site do SMS

As informações de quando o Backup do SMS 2003 foi iniciado, concluído ou falhou podem ajudar os administradores do SMS na auditoria de atividades de backup. Você pode agendar o Backup do SMS para ser executado periodicamente, fazendo o backup dos dados, das diretivas e da configuração do SMS. É importante monitorar falhas deste processo de backup e tomar as medidas corretivas. Mesmo quando o Backup do SMS tem êxito, ele afeta a disponibilidade do serviço porque esse processo pára e inicia os serviços SMS Site Component Manager, SMS Executive e SMS SQL Monitor. O monitoramento do Backup do SMS ajuda a acompanhar os tempos de inatividade conhecidos desses serviços, pois os alertas sobre a parada desses serviços são suprimidos durante o processo de backup. As seguintes regras dão suporte ao monitoramento do Backup de site do SMS:

  • Serviço do SMS 2003 parou a execução: SMS_SITE_BACKUP
  • Serviço do SMS 2003 iniciou a execução: SMS_SITE_BACKUP
  • Status do SMS 2003: Backup do Site concluído com êxito
  • Status do SMS 2003: falha no Backup do Site

Conteúdo de conhecimento do produto para todos os alertas

Os administradores podem consultar o conteúdo da base de dados do produto para todos os alertas para obter assistência específica na identificação de um problema e em sua resolução. Para acessar o conteúdo da base de dados do produto, clique com o botão direito do mouse no nome de qualquer regra, clique em Propriedades e clique na guia Conhecimento do Produto.

Grupos de computadores para todas as funções de cliente e servidor do SMS 2003

A resolução de grupos de computadores está definida no momento para funções de cliente e servidor do SMS específicas. Isso fornece aos administradores um controle maior no gerenciamento da replicação de regras para agentes do Operations Manager 2007. Os administradores podem desabilitar os grupos de computadores padrão ou definir novos grupos de computadores com base nos atributos de computadores e grupos de computadores padrão.

Monitoramento expandido

As regras fornecidas no Pacote de Gerenciamento do SMS 2003 aborda o monitoramento do serviço básico, da medição de desempenho e dos limites de desempenho para Pacotes de Gerenciamento do SQL Server, do IIS, do Microsoft Windows® 2000 e do sistema operacional Windows Server® 2003 básico. Você pode habilitar o suporte básico no Pacote de Gerenciamento do SMS 2003 para esses Pacotes de Gerenciamento ou pode manter as configurações desabilitadas e habilitar as regras apropriadas em outros Pacotes de Gerenciamento.

  • Use o Pacote de Gerenciamento do SQL Server para expandir o monitoramento dos pontos de gerenciamento e servidores de banco de dados do site do SMS que possuem dependências do SQL Server.
  • Use o Pacote de Gerenciamento do IIS para monitorar o IIS em pontos de relatório, pontos de gerenciamento e pontos de localizador do servidor. O Pacote de Gerenciamento do IIS também pode monitorar pontos de distribuição com o BITS habilitado.
  • Use O Pacote de Gerenciamento do Microsoft Windows 2000 e do sistema operacional Windows Server 2003 básico para monitorar componentes básicos do Windows, como as estatísticas de CPU, disco e memória.

Há outros Pacotes de Gerenciamento para os quais o Pacote de Gerenciamento do SMS 2003 não fornece regras e que podem aprimorar o monitoramento da infra-estrutura do SMS 2003.

  • Use o Pacote de Gerenciamento do Balanceamento de Carga de Rede do Windows se estiver usando o Balanceamento de Carga de Rede para dar suporte a vários pontos de gerenciamento na hierarquia do SMS, por motivos de escalabilidade.
  • Use o Pacote de Gerenciamento do Diretório do Windows Active Directory® para monitorar a integridade da infra-estrutura do Active Directory.

Se você implantar vários Pacotes de Gerenciamento no ambiente, poderá receber alertas redundantes baseados nas regras que existem nos vários Pacotes de Gerenciamento. Se você desabilitar as regras de monitoramento redundantes, poderá afetar a precisão da exibição de estado dos Pacotes de Gerenciamento implantados. Considere cuidadosamente a opção entre receber alertas redundantes e ter o monitoramento de estado funcionando para cada Pacote de Gerenciamento implantado. Dependendo dos Pacotes de Gerenciamento adicionais que você implantou, examine essas regras redundantes para identificar aquelas que deseja habilitar no seu ambiente. Depois de instalar esses Pacotes de Gerenciamento, confirme se eles estão personalizados conforme necessário, configurados corretamente e se as regras apropriadas estão habilitadas.

Status da execução de programa de distribuição de software

O SMS Advanced Client pode relatar falhas do programa por meio do Pacote de Gerenciamento.

Os administradores podem marcar a caixa de seleção Generate MOM alert if this program fails na guia MOM da caixa de diálogo Propriedades do Programa.

Procedimento

A habilitação de alertas do Operations Manager 2007 se a execução de um programa do SMS 2003 falhar exige as seguintes etapas:

Para habilitar os alertas do Operations Manager 2007 para um programa do SMS 2003

  1. No console do Systems Management Server, navegue até Systems Management Server / Site Database - <nome do servidor do site> / Pacotes.

  2. No painel de detalhes, clique com o botão direito do mouse no Programa e selecione Propriedades. A caixa de diálogo de propriedades do programa será aberta.

  3. Selecione a guia MOM

  4. Clique na caixa de seleção Generate MOM alert if this program fails to run. Clique em OK.

Consulte também

Implantando o Pacote de Gerenciamento do SMS 2003

Outros recursos

Referência do Pacote de Gerenciamento do Microsoft System Management Server 2003


Implantando o Pacote de Gerenciamento do SMS 2003

Antes de implantar o Pacote de Gerenciamento do Microsoft® Systems Management Server (SMS) 2003, reveja o Guia de Implantação do Microsoft Operations Manager 2007 na página da Web do Operations Manager 2007 (http://go.microsoft.com/fwlink/?LinkID=83259). Esta seção fornece instruções adicionais para implantar os pacotes de gerenciamento do Operations Manager.

Para implantar o Pacote de Gerenciamento do SMS 2003, você deve concluir os seguintes processos:

  • Implantar o agente Operations Manager 2007 em todos os computadores do componente do servidor SMS.
Observação
Se o modo de manutenção ou o mapeamento de topologia do Operations Manager 2007 for necessário, você deve implantar o SMS 2003 SP3 antes de importar o pacote de gerenciamento do SMS 2003 ou instalar o agente Operations Manager 2007.

  • Importar o Pacote de Gerenciamento do SMS 2003 para um grupo de configuração do Operations Manager 2007.
  • Configurar os Provedores SMS e os servidores do Banco de Dados do Site do SMS para que os agentes do Operations Manager 2007 possam usar proxy em outros computadores.
  • Concluir as tarefas de teste e de teste piloto recomendadas.
  • Concluir as tarefas de ajuste recomendadas.

Nesta Seção

Implantando o agente do Operations Manager 2007

Testando e operando o Pacote de Gerenciamento

Personalizando o Pacote de Gerenciamento

Consulte também

Cenários de monitoramento do Pacote de Gerenciamento

Outros recursos

Visão geral do Pacote de Gerenciamento do System Management Server 2003
Executando tarefas de operações do Pacote de Gerenciamento do SMS 2003
Solução de problemas do Pacote de Gerenciamento do SMS 2003
Referência do Pacote de Gerenciamento do Microsoft System Management Server 2003


Implantando o agente do Operations Manager 2007

O agente do Operations Manager é executado em cada computador monitorado pelo Operations Manager. Para exibir os grupos de computadores monitorados pelo Pacote de Gerenciamento do SMS 2003, consulte a seção Grupos de computadores do SMS 2003 neste guia. O agente do Operations Manager 2007 coleta dados de monitoramente no computador gerenciado, aplica regras a esses dados e envia os dados resultantes ao Data Consolidator Agent Manager (DCAM). O monitoramento da funcionalidade em um computador agente é fornecido pelo Serviço do Operations Manager 2007 (HealthService.exe), pelo Host do Operations Manager 2007 (MonitoringHost.exe) e pela Conta de Ação do Agente.

Para implantar o agente do Operations Manager 2007, você pode usar o assistente para instalação do Operations Manager 2007 ou a distribuição de software do SMS. Para obter detalhes sobre a implantação do agente do Operations Manager 2007 e o uso do assistente para instalação do Operations Manager 2007, consulte a seção sobre a descoberta de computadores e implantação de agentes do MOM no Guia de Implantação do Microsoft Operations Manager 2007. Para obter mais informações, consulte a página da Web Operations Manager 2007 (http://go.microsoft.com/fwlink/?LinkID=83259).

Observação
É recomendável executar o agente do Operations Manager 2007 nos computadores Provedor do SMS usando a conta do sistema local ou uma conta com direitos suficientes para acessar os namespaces WMI do SMS 2003 root, root\cimv2, root\smse as chaves e subchaves do Registro do SMS.

Para determinar se o monitoramento sem agente pode ser usado no seu ambiente, consulte o Suporte ao monitoramento sem agente em Cenários de monitoramento do Pacote de Gerenciamento.

Configurando computadores agente para serem executados em cenários com privilégios baixos

O monitoramento da funcionalidade em um computador agente é fornecido pelo Serviço do Operations Manager 2007 (HealthService.exe), pelo Host do Operations Manager 2007 (MonitoringHost.exe) e pela Conta de Ação do Agente. No Microsoft Windows® 2000, a Conta de Ação deve ser um membro do grupo de administradores locais. No Microsoft Windows™ 2003, você pode usar uma conta com privilégios baixos para a Conta de Ação do Agente sob determinadas circunstâncias. Contudo, a configuração da Conta de Ação e do contexto do usuário que o processo do Serviço do Operations Manager 2007 e do Host do Operations Manager 2007 executa com os direitos e permissões necessários para executar os recursos do Pacote de Gerenciamento do SMS 2003 exige uma configuração manual significativa no computador agente. No Microsoft Windows Server™ 2003, A Conta de Ação do Agente deve possuir os seguintes direitos e permissões mínimos do usuário:

  • Membro do grupo Usuários locais
  • Acesso aos logs de eventos do Windows
  • Permissão para gerenciar o log de segurança e auditoria (SeSecurityPrivilege)
  • Permissão para gerar auditorias de segurança (SeAuditPrivilege)
  • Permissão para permitir o logon local (SeInteractiveLogonRight)

Em um cenário com privilégios baixos, o Pacote de Gerenciamento do SMS 2003 exige que a conta usada para a Conta de Ação do Agente possua direitos e permissões adicionais. A tabela a seguir detalha os direitos de acesso que devem ser configurados manualmente.

Tipos de acesso exigidos pelo Pacote de Gerenciamento do SMS 2003

Recurso | Tipo de acesso | Instruções
Log de eventos do Windows | Leitura | A Conta de Ação deve receber o privilégio de Gerenciar o log de segurança e auditoria usando a diretiva local ou global.
Chaves do Registro do SMS | Leitura | HKLM\Software\Microsoft\SMS Adicione a Conta de Ação às propriedades do Registro e forneça o acesso de leitura herdado por todas as subchaves.
Chaves do Registro dos Serviços do Win32 | Leitura | HKLM\System\CurrentControlSet\Services Adicione a Conta de Ação ao grupo de usuários locais.
Arquivos temporários gerados por scripts | Leitura e gravação | %Windir%\Temp Adicione a Conta de Ação ao grupo de usuários locais .
Arquivos de log gerados por scripts | Leitura e gravação | %Windir%\Microsoft Operations Manager Adicione a Conta de Ação às propriedades da pasta.
Arquivos de log do SMS | Leitura | \SMS\Logs Adicione a Conta de Ação às propriedades da pasta.
Namespaces do WMI | Leitura | root e root\cimv2 Nenhuma ação é necessária.
Namespaces do WMI do SMS | Leitura | Nenhuma ação é necessária.
Classes do WMI do SMS | Leitura | SMS_Site SMS_R_System SMS_SystemResourceList SMS_SiteSystemSummarizer Adicione a Conta de Ação à classe para todas as instâncias
Direitos de logon de segurança para a instância padrão | Conceder acesso | Para a instância padrão em um computador SQL Server gerenciado, a Conta de Ação deve receber direitos de Conceder acesso para logons de segurança. No SQL Server Enterprise Manager, adicione a Conta de Ação ao nó: instancename\Security\Logins.
Acesso ao banco de dados Mestre na instância padrão (necessário para identificar o banco de dados do Site do SMS) | Permissão | Para a instância padrão em um computador SQL Server gerenciado, a Conta de Ação deve receber direitos de Permissão para o banco de dados Mestre. No SQL Server Enterprise Manager, adicione a Conta de Ação ao nó: instancename\Databases\Master\Users. Mantenha todas as permissões padrão associadas a este novo usuário.
Acesso ao banco de dados do Site to SMS na instância padrão | Permissão | Para a instância padrão em um computador SQL Server gerenciado, a Conta de Ação deve receber direitos de Permissão para o banco de dados do Site do SMS. No SQL Server Enterprise Manager, adicione a Conta de Ação ao nó: instancename\Databases\<SMS site>\Users. Mantenha todas as permissões padrão associadas a este novo usuário.

Consulte também

Testando e operando o Pacote de Gerenciamento
Personalizando o Pacote de Gerenciamento
Problemas conhecidos do SMS2003

Outros recursos

Solução de problemas do Pacote de Gerenciamento do SMS 2003


Testando e operando o Pacote de Gerenciamento

Além das recomendações gerais para testar os Pacotes de Gerenciamento descritas no Guia de Implantação do Microsoft Operations Manager 2007, esta seção lista tarefas de teste e piloto apropriadas para o Pacote de Gerenciamento do SMS 2003. Para obter mais informações, consulte a página da Web Operations Manager 2007 (http://go.microsoft.com/fwlink/?LinkID=83259).

Tarefas de teste

  • Verifique se os grupos de computadores do SMS 2003 estão preenchidos com computadores que executam o SMS 2003.
  • Depois de habilitar as regras relevantes, verifique se os modos de exibição e os relatórios do Operations Manager 2007 estão funcionando corretamente. Estão incluídos os modos de exibição relacionados com as taxas de processamento e os registros posteriores do SMS.
  • Por padrão, algumas regras relacionadas com outros Pacotes de Gerenciamento, como os Pacotes de Gerenciamento do IIS e do SQL Server, estão desabilitadas no Pacote de Gerenciamento do SMS 2003. Dependendo dos Pacotes de Gerenciamento adicionais que você implantou, examine essas regras desabilitadas para identificar aquelas que deseja habilitar no seu ambiente.
  • Por padrão, todas as regras de medição de desempenho estão desabilitadas, de forma a minimizar o impacto sobre a CPU, a memória e os recursos de rede do agente. Essas regras podem ser habilitadas para um monitoramento mais aprofundado do agente.
  • Alguns scripts do SMS que são executados em um computador Provedor do SMS, um servidor de banco de dados do site do SMS ou que acessam um banco de dados do site do SMS não são executados no modo sem agente. Verifique se todos os computadores nos grupos de computadores Provedor do Microsoft SMS 2003 e Servidor de banco de dados do site do Microsoft SMS estão configurados como computadores gerenciados por agentes. Além disso, como alguns desses scripts podem usar o proxy para eventos, verifique se esses agentes estão configurados para habilitar o proxy.

Tarefas de teste piloto

  • Verifique se ou processo de implantação ou atualização do Pacote de Gerenciamento do SMS 2003 foi concluído com êxito a partir da versão anterior.
  • Verifique e edite os limites personalizados para seu ambiente, usando o modo de exibição Health Monitor do limite de desempenho.
  • Habilite as regras de desempenho em estágios, de forma a avaliar o impacto dessas regras sobre o desempenho do Operations Manager 2007.
  • Verifique se os grupos de computadores do SMS 2003 estão preenchidos com computadores que executam o SMS 2003.
  • Depois de habilitar as regras relevantes, verifique se os modos de exibição e os relatórios do Operations Manager 2007 estão funcionando corretamente. Estão incluídos os modos de exibição relacionados com as taxas de processamento, os totais de processamento e os registros posteriores do SMS.
  • Por padrão, algumas regras relacionadas com outros Pacotes de Gerenciamento estão desabilitadas. Dependendo dos Pacotes de Gerenciamento adicionais que você implantou, examine as regras desabilitadas para identificar aquelas que deseja habilitar no seu ambiente.
  • Por padrão, algumas regras de desempenho estão desabilitadas, de forma a minimizar o impacto sobre a CPU, a memória e os recursos de rede do agente. Essas regras podem ser habilitadas para um monitoramento mais aprofundado do agente.
  • Verifique se os eventos baseados na execução de scripts do SMS 2003 não são gerados. Normalmente, eles indicam problemas com permissões de acesso do script.
  • Verifique se o dimensionamento do DCAM e do SQL Server são suficientes para sua carga de produção.
  • Verifique os requisitos de pessoal e processos de operações.
  • Verifique se a paginação e a notificação por email estão funcionando corretamente.
  • Verifique se as permissões usadas pelo Operations Manager 2007 são suficientes para a execução correta, sem serem excessivas.
  • Se o agente do Operations Manager 2007 não for especificado para ser executado na conta do sistema local, verifique se os direitos de segurança mínimos foram atingidos. Para obter mais informações, consulte a seção "Configurando computadores agente para serem executados em cenários com privilégios baixos" na seção Implantando o agente do Operations Manager 2007 neste guia.
  • Verifique se as funções do Servidor e do Cliente do SMS aparecem no modo de exibição Estado. Clique em um computador que está hospedando cada uma dessas funções e verifique se os componentes estão visíveis no painel de instâncias.
  • Verifique se as tarefas do SMS Administrator Console estão funcionando, clicando em uma tarefa. Se a execução da tarefa falhar, verifique se o SMS 2003 SP2 Administrator Console foi instalado e se o usuário fez logoff e fez logon novamente na conclusão da instalação do console.
  • No modo de exibição Estado, clique em um Servidor do SMS e em um Cliente do SMS para verificar se a página Funções mostra as funções e os dados de propriedades apropriados.
  • No painel Monitoramento, navegue até Microsoft Systems Management Server (SMS) 2003 e clique em SMS 2003 Site Hierarchy Diagram. Verifique se todos os sistemas do site são exibidos para os sites que possuem o agente do Operations Manager 2007 instalado localmente no Provedor do SMS. Se um sistema do site não for exibido, verifique no SMS Administrator Console se o sistema do site foi descoberto pelo site e se aparece a coleção All Systems.

Depois de concluir os testes piloto, exporte o Pacote de Gerenciamento do SMS 2003 para fazer backup das alterações.

Consulte também

Personalizando o Pacote de Gerenciamento
Implantando o agente do Operations Manager 2007
Problemas conhecidos do SMS2003

Outros recursos

Solução de problemas do Pacote de Gerenciamento do SMS 2003


Personalizando o Pacote de Gerenciamento

Para um monitoramento ideal, o Pacote de Gerenciamento do SMS 2003 pode ser personalizado com base nas necessidades comerciais de sua organização. Se as regras existentes não atenderem às necessidades de sua organização, modifique-as ou crie novas regras.

Observação Sempre faça backup do Pacote de Gerenciamento do SMS 2003 antes de fazer alterações. O Assistente para Exportação do Pacote de Gerenciamento do Operations Manager 2007 permite fazer backup de Pacotes de Gerenciamento sem lacre.

A personalização pode incluir:

  • Habilitação e desabilitação de regras usando substituições.
  • Criação de novas regras.
  • Modificação de critérios de alertas, da severidade de alertas e supressão de alertas.
  • Configuração de limites personalizados para regras. Todas as regras de limites de desempenho podem ser configuradas. Se o limite padrão não for o ideal, você poderá receber alertas desnecessários ou poderá não ser alertado devido à definição muito alta de um limite para seu ambiente.
  • Configuração do limite de regras de eventos de monitoramento da caixa de entrada e do intervalo de sondagem usando substituições ou, no caso de valores de limites, editando o modo de exibição XML.
  • Adição de uma nova regra de eventos de monitoramento da caixa de entrada. Para adicionar uma nova regra de monitoramento da caixa de entrada, crie uma nova regra no Pacote de Gerenciamento Padrão e, em seguida, crie substituições para os parâmetros de entrada de scripts (FileCountThreshold e InboxDirectoryName) e agendamento.
  • Configuração de intervalos de sondagem para medições de desempenho usando substituições.
  • Adição de conteúdo à base de dados de conhecimento da empresa.
  • Personalização de respostas a alertas por meio da alteração ou adição de novas respostas a regras ou da adição de regras de processamento de alertas para esses alertas.
  • A habilitação de regras de medição de desempenho no agente, no servidor que executa o Operations Manager 2007 e o banco de dados gera uma grande quantidade de dados e possivelmente pode causar problemas de desempenho. As regras de medição de desempenho estão desabilitadas por padrão para permitir que você decida se um possível impacto no desempenho seria aceitável. Examine as regras de desempenho e habilite-as em pequenos lotes, de forma que você tenha acesso ao impacto que elas têm sobre o desempenho do Operations Manager 2007, incluindo o tamanho do banco de dados.
  • Configuração de parâmetros para regras de eventos de monitoramento da caixa de entrada e regras relacionadas. Modifique os dois scripts, FileCountThreshold e InboxDirectoryName,, criando uma substituição.
  • Exame de regras com relação à sua aplicação no seu ambiente. Por padrão, algumas regras relacionadas com outros Pacotes de Gerenciamento estão desabilitadas. Dependendo dos Pacotes de Gerenciamento adicionais que você implantou, examine as regras desabilitadas para identificar aquelas que deseja habilitar no seu ambiente.

Para obter mais informações sobre as personalizações do Pacote de Gerenciamento e sobre como exportá-las, consulte os tópicos sobre Pacotes de Gerenciamento no Operations Manager 2007 e sobre como exportar personalizações do Pacote de Gerenciamento na Ajuda do Operations Manager 2007.

Monitoramento da caixa de entrada

O Assistente para Exportação do Operations Manager 2007 permite salvar as alterações do Pacote de Gerenciamento Padrão antes de fazer outras alterações.

Configurando as regras de monitoramento da caixa de entrada

Para implantar estas regras em servidores do site central, principal e secundário, crie novas regras no Pacote de Gerenciamento com base nas regras de Servidores do site do SMS - Comum. Essas regras poderão então ser atribuídas ao grupo de regras de processamento apropriado para o servidor do site, modificando o limite e habilitando a regra.

  • Caixa de entrada do SMS 2003: monitoramento da caixa de entrada
  • Caixa de entrada do SMS 2003: Erro de script de monitoramento da caixa de entrada
  • Caixa de entrada do SMS 2003: limite excedido

A regra de processamento de eventos Caixa de entrada do SMS 2003: limite excedido monitora eventos do script SMS 2003: Monitor Inbox script error. Um alerta exclusivo é gerado para cada caixa de entrada que está acima da contagem limite especificada.

A configuração de limite padrão para esse script é de 10.000 arquivos em uma caixa de entrada. Você pode criar uma substituição para este valor no Pacote de Gerenciamento Padrão, para este ou qualquer parâmetro do script. Se excedido, um evento de “limite excedido” será gerado. Você pode modificar as configurações do limite calculando a carga diária esperada nos servidores para cada processo que funciona corretamente e adicionando uma porcentagem aceitável de buffer. Por padrão, as regras de monitoramento da caixa de entrada são executadas uma vez por dia, com incrementos de 15 minutos, começando à 1h00. Para minimizar o impacto no desempenho, é recomendável manter este intervalo ou ajustá-lo de forma a minimizar as sobreposições na execuções de scripts entre as regras de monitoramento da caixa de entrada.

A tabela a seguir lista as regras de monitoramento da caixa de entrada, os limites padrão e as caixas de entrada que são monitoradas no provedor do SMS Executive.

Monitoramento da caixa de entrada do SMS Executive

Nome da regra de monitoramento da caixa de entrada | Limite padrão | Nome da caixa de entrada
Caixa de entrada do SMS 2003: erro de script de monitoramento da caixa de entrada | n/d | n/d
Caixa de entrada do SMS 2003: limite excedido | n/d | n/d
Caixa de entrada do SMS 2003: Monitor auth\dataldr.box | 10000 | Inboxes\auth\dataldr.box
Caixa de entrada do SMS 2003: Monitor auth\ddm.box | 10000 | Inboxes\auth\ddm.box
Caixa de entrada do SMS 2003: Monitor auth\sinv.box | 10000 | Inboxes\auth\sinv.box
Caixa de entrada do SMS 2003: Monitor compsumm.box\repl | 10000 | Inboxes\ compsumm.box\repl
Caixa de entrada do SMS 2003: Monitor dataldr.box | 10000 | Inboxes\ dataldr.box
Caixa de entrada do SMS 2003: Monitor ddm.box | 10000 | Inboxes\ ddm.box
Caixa de entrada do SMS 2003: Monitor despoolr.box\receive | 10000 | Inboxes\despoolr.box\receive
Caixa de entrada do SMS 2003: Monitor offermgr.box\INCOMING | 10000 | Inboxes\offermgr.box\INCOMING
Caixa de entrada do SMS 2003: Monitor offersum.box\repl | 10000 | Inboxes\ offersum.box\repl
Caixa de entrada do SMS 2003: Monitor replmgr.box\incoming | 10000 | Inboxes\replmgr.box\incoming
Caixa de entrada do SMS 2003: Monitor schedule.box\outboxes\LAN | 10000 | Inboxes\ schedule.box\outboxes\LAN
Caixa de entrada do SMS 2003: Monitor statmgr.box\statmsgs | 10000 | Inboxes\statmgr.box\statmsgs
Caixa de entrada do SMS 2003: Monitor swmproc.box\usage | 10000 | Inboxes\swmproc.box\usage

Procedimento para substituir as regras de eventos de monitoramento da caixa de entrada

Para substituir uma regra de eventos de monitoramento da caixa de entrada, o servidor do site do Operations Manager 2007 deve descobrir os objetos do servidor do site do SMS 2003 do tipo Microsoft SMS 2003 Site Servers.

Para substituir as regras de eventos de monitoramento da caixa de entrada

  1. No Console de Operações do Operations Manager 2007, selecione o botão Criação.

  2. Navegue até Criação / Objetos do Pacote de Gerenciamento / Regras.

  3. Delimite os servidores do site do Microsoft SMS 2003.

  4. Clique com o botão direito do mouse em uma regra de eventos de monitoramento da caixa de entrada do SMS 2003 apropriada, como Caixa de entrada do SMS 2003: Monitor schedule box\requests, selecione Substituições, Override the Rule e clique em Para todos os objetos do tipo: Microsoft SMS 2003 Site Servers.

  5. Em Propriedades da Substituição, marque a caixa de seleção Habilitado da substituição e defina Substituir Definição como True.

  6. Em Propriedades da Substituição, marque a caixa de seleção FileCountThreshold da substituição e defina Substituir Definição com o valor do limite desejado.

  7. Clique em OK. Clique em OK. Os valores de limites modificados são distribuídos para os servidores.

Procedimento para editar o monitoramento de limites de contadores de desempenho

Para editar o monitoramento dos limites de contadores de desempenho, execute as seguintes etapas:

Para editar o monitoramento de limites de contadores de desempenho

  1. No Console de Operações do Operations Manager 2007, selecione o botão Criação.

  2. Navegue até Criação / Objetos do Pacote de Gerenciamento / Monitores.

  3. Altere o escopo para o Servidor do SMS.

  4. Navegue até SMS Server / Entity Health / MOM 2005 Computer Role Health e selecione a função do computador apropriada, como SS para servidor do site.

  5. Clique duas vezes na regra do monitor de limite de desempenho a ser editada. A caixa de diálogo Performance Threshold Properties será aberta.

  6. Selecione a guia Configuração.

  7. Clique em Editar. A caixa de diálogo Configuração Xml será aberta.

  8. No texto XML, edite o valor do limite a ser modificado.

    • Especifique <ValueExpression> aninhada em <CriticalErrorExpression> para alterar o limite de erro crítico.
    • Especifique <ValueExpression> aninhada em <WarningExpression> para alterar o limite de aviso.

  9. Clique em OK. Clique em OK. Os valores de limites modificados são distribuídos para os servidores.

Consulte também

Testando e operando o Pacote de Gerenciamento
Configuração suportada do SMS
Cenários de monitoramento do Pacote de Gerenciamento

Outros recursos

Solução de problemas do Pacote de Gerenciamento do SMS 2003
Referência do Pacote de Gerenciamento do Microsoft System Management Server 2003


Executando tarefas de operações do Pacote de Gerenciamento do SMS 2003

Recomenda-se que você analise e resolva prontamente todos os alertas para identificar aqueles que são importantes ou potencialmente críticos. Além disso, você deve executar outras tarefas com freqüência, dependendo do seu ambiente. Muitos problemas importantes não geram alertas, mas ainda assim exigem atenção periódica. O Pacote de Gerenciamento do Microsoft® Systems Management Server (SMS) 2003 tem exibições e relatórios que exibem dados ao longo do tempo e apresentam padrões que indicam problemas. Analise as exibições e os relatórios para resolver os problemas antes que eles gerem alertas.

Você deve executar as tarefas diárias, semanais e mensais como especificado nesta seção, mas ajuste a freqüência delas para atender às necessidades específicas do seu ambiente.

Nesta seção

Tarefas diárias do SMS 2003

Tarefas semanais do SMS 2003

Tarefas mensais do SMS 2003

Tarefas do console do administrador do SMS 2003

Consulte também

Cenários de monitoramento do Pacote de Gerenciamento
Implantando o Pacote de Gerenciamento do SMS 2003

Outros recursos

Visão geral do Pacote de Gerenciamento do System Management Server 2003
Executando tarefas de operações do Pacote de Gerenciamento do SMS 2003
Solução de problemas do Pacote de Gerenciamento do SMS 2003
Referência do Pacote de Gerenciamento do Microsoft System Management Server 2003


Tarefas diárias do SMS 2003

É recomendável executar as seguintes tarefas diariamente:

  • Examinar todos os alertas abertos.
  • Examinar as associações do grupo de computadores.
  • Verificar se todos os agentes do Operations Manager 2007 estão se comunicando com o servidor do Operations Manager 2007.
  • Examinar os registros posteriores de desempenho.
  • Examinar as taxas de processamento de desempenho.
  • Examinar o desempenho do servidor e do agente do Operations Manager 2007.
  • Examinar as associações do grupo de notificações ou os grupos de notificação da regra de processamento de eventos.
  • Examinar os backups do site do SMS 2003.
  • Examinar eventos (opcional).

Examinar todos os alertas abertos

Os alertas do Pacote de Gerenciamento do SMS 2003 são exibidos no seguinte formato de descrição de alertas:

$Computer$ <Rule Name>

$Description$

Event details

Examine todos os alertas do Operations Manager 2007 para assegurar que eles sejam resolvidos oportunamente. Você pode usar qualquer dos seguintes métodos para examinar os alertas abertos:

  • No Console de Operações, clique no botão Monitoramento, expanda Microsoft Systems Management Server (SMS) 2003 e clique em Alertas.
  • No Console de Operações, clique no botão Monitoramento, expanda Microsoft Systems Management Server (SMS) 2003 e clique em Geral. Selecione Alerts that are New in the last 72 hours.
  • Os alertas podem ser exibidos por computador ou por grupo de computadores clicando em Computer and Groups. Para exibir um resumo por severidade do alerta, clique com o botão direito do mouse no grupo de computadores do SMS 2003 que deseja examinar, selecione Exibir e clique em Alertas.
  • Os alertas podem ser exibidos por meio do modo de exibição Estado. O modo de exibição Estado mostra uma lista de computadores e o alerta com a severidade mais alta. Clique duas vezes em qualquer computador para obter uma listagem de seus alertas atuais.
  • Os alertas podem ser exibidos por meio do modo de exibição Diagrama. O modo de exibição Diagrama hierárquico do SMS 2003 mostra uma representação gráfica da hierarquia do SMS 2003. Cada computador possui uma anotação de status que indica seu alerta de severidade mais alto. Clique duas vezes em qualquer computador para obter uma listagem de seus alertas atuais.

É recomendável examinar todos os novos alertas na seguinte ordem:

  1. Alertas de serviço principais do SMS 2003
  2. Alertas de serviço dependentes do SMS 2003
  3. Alertas baseados no resumidor de status do sistema do site do SMS 2003
  4. Alertas de Integridade do ponto de gerenciamento do SMS 2003
  5. Alertas baseados em mensagens de status do SMS 2003
  6. Alertas de componentes do SMS 2003
  7. Alertas de registro posterior do SMS 2003
  8. Alertas de monitoramento da Caixa de Entrada do SMS 2003
  9. Alertas de falhas no Backup de site do SMS 2003
  10. Alertas de falhas em programas do SMS 2003

Examinar as associações do grupo de computadores

A associação do grupo de computadores pode ser verificada usando o Operations Manager 2007.

  • No Console de Operações, clique no botão Criação, clique em Grupos e clique com o botão direito do mouse no grupo de computadores apropriado do SMS 2003. Verifique se cada grupo de computadores exibido contém os computadores corretos.

Verificar se os agentes estão se comunicando com o servidor do Operations Manager 2007

Falhas de comunicação entre o agente e a infra-estrutura de monitoramente impede que você receba alertas. Verifique se o agente e o servidor que executam o Operations Manager 2007 estão se comunicando por meio da execução dos relatórios de Disponibilidade. Para obter mais informações, consulte o tópico "Como criar um relatório de disponibilidade no Operations Manager 2007" na Ajuda do Operations Manager 2007.

Examinar os registros posteriores de desempenho e as taxas de processamento de desempenho

Os Registros posteriores de desempenho e as Taxas de processamento de desempenho são extremamente úteis na detecção de tendências diárias e na compreensão do que acontece na hierarquia do SMS. Os Registros posteriores de desempenho e as Taxas de processamento de desempenho podem ser exibidos no Operations Manager 2007.

Para examinar os registros posteriores de desempenho

Para examinar os registros posteriores de desempenho, execute as seguintes etapas:

Para examinar os registros posteriores de desempenho

  1. No Console de Operações, clique no botão Monitoramento e expanda Microsoft Systems Management Server (SMS) 2003.

  2. Expanda Desempenho e, em seguida, Backlogs. Clique na subpasta do componente apropriado. Use a opção de contador para reduzir os dados exigidos, o número de computadores ou para selecionar apenas os computadores pertinentes.

Para examinar as taxas de processamento de desempenho

Para examinar as taxas de processamento de desempenho, execute as seguintes etapas:

Para examinar as taxas de processamento de desempenho

  1. No Console de Operações, clique no botão Monitoramento e expanda Microsoft Systems Management Server (SMS) 2003.

  2. Expanda Desempenho e, em seguida, Backlogs. Clique na subpasta do componente apropriado. Use a opção de contador para reduzir os dados exigidos, o número de computadores ou para selecionar apenas os computadores pertinentes.

Monitoramento de backup do site do SMS 2003

Habilite a tarefa de manutenção de Backup do site do SMS e agende backups conforme necessário em seu ambiente empresarial. Quando o serviço Backup do site do SMS for iniciado, primeiro ele parará todos os serviços do SMS, incluindo SMS_EXECUTIVE, SMS_SQL_MONITOR e SMS_SITE_COMPONENT_MANAGER. O processo de Backup do site do SMS não dá suporte a backups em tempo de execução ao:

  • Copiar partes da pasta de instalação do SMS para o caminho de exportação do backup.
  • Fazer backup dos vários valores do Registro do SMS.
  • Fazer backup do banco de dados do site do SMS em um servidor que executa o Microsoft SQL Server™.

Quando o backup for concluído, o serviço Backup do site do SMS reiniciará os serviços do SMS. Essas paradas e inícios de serviços são normais durante o processo de backup e não indicam qualquer erro crítico. Os alertas que são esperados dessas paradas de serviços são suprimidos durante o Backup do site do SMS. Você pode correlacionar essas paradas e inícios de serviços, além das paradas e inícios do Backup do site do SMS. Para fazê-lo, habilite as regras a seguir. Essas regras geram alertas informativos quando o serviço Backup do site do SMS inicia ou pára:

  • Serviço do SMS 2003 parou a execução: SMS_SITE_BACKUP
  • Serviço do SMS 2003 iniciou a execução: SMS_SITE_BACKUP

Os seguintes alertas são gerados quando o serviço Backup do site do SMS falha ao iniciar ou pára inesperadamente:

  • Falha de serviço do SMS 2003: o SMS_SITE_BACKUP foi finalizado inesperadamente
  • Falha de serviço do SMS 2003: o SMS_SITE_BACKUP parou ao iniciar
  • Falha de serviço do SMS 2003: falha do SMS_SITE_BACKUP ao iniciar
  • Falha de serviço do SMS 2003: o SMS_SITE_BACKUP não pôde fazer logon
  • Falha de serviço do SMS 2003: o SMS_SITE_BACKUP depende de outro serviço que falhou ao iniciar ou que não existe

Se você observar um alerta indicando que o serviço foi finalizado inesperadamente, verifique se todos os serviços parados foram reiniciados. O serviço Backup do site do SMS pode ter sido finalizado antes de reiniciar esses serviços.

Os seguintes alertas de mensagem de status são gerados para mostrar o êxito ou a falha do processo de backup:

  • Status do SMS 2003: backup do site concluído com êxito
  • Status do SMS 2003: falha no backup do site

O backup pode ter falhado devido a problemas de acesso, espaço em disco insuficiente, falha ao iniciar ou parar determinados serviços ou falhas em operações do SQL Server.

Examinar eventos

Examine os eventos regularmente porque eles indicam falhas não-críticas e fornecem uma idéia sobre o funcionamento do agente do Operations Manager 2007.

Para examinar os eventos

Para examinar os eventos, execute as seguintes etapas:

Para examinar os eventos

  1. No Console de Operações clique no botão Monitoramento.

  2. Expanda Microsoft Systems Management Server (SMS) 2003 e clique em Eventos.

Consulte também

Tarefas semanais do SMS 2003
Tarefas mensais do SMS 2003
Tarefas do console do administrador do SMS 2003

Outros recursos

Executando tarefas de operações do Pacote de Gerenciamento do SMS 2003
Solução de problemas do Pacote de Gerenciamento do SMS 2003
Referência do Pacote de Gerenciamento do Microsoft System Management Server 2003


Tarefas semanais do SMS 2003

Além das tarefas realizadas diariamente, execute as seguintes tarefas semanalmente:

  • Examinar os relatórios. Para obter uma lista dos relatórios incluídos no Pacote de Gerenciamento do SMS 2003, consulte a seção Relatórios do SMS 2003 neste guia.
  • Examinar os alertas, eventos e o desempenho da última semana com relação a possíveis problemas e tendências.
  • Se necessário, ajuste as configurações do Operations Manager 2007, como o intervalo de pulsação do agente do Operations Manager 2007, o intervalo de verificação de status do Monitoramento de Serviços, o intervalo de verificação de pulsação do Gerenciador de Agentes, os intervalos de descoberta e os parâmetros de grooming do banco de dados.
  • Examinar o histórico de backup dos sites do SMS.
  • Examinar o SMS 2003 no histórico de backup do grupo de configuração do Operations Manager 2007.
  • Examinar o banco de dados e o log do SQL Server.
  • Executar os relatórios de disponibilidade do SMS 2003 para obter a disponibilidade dos servidores do SMS e de seus componentes.
  • Verificar a hierarquia do SMS usando o Diagrama Hierárquico do SMS 2003.

Consulte também

Tarefas diárias do SMS 2003
Tarefas mensais do SMS 2003
Tarefas do console do administrador do SMS 2003

Outros recursos

Executando tarefas de operações do Pacote de Gerenciamento do SMS 2003
Solução de problemas do Pacote de Gerenciamento do SMS 2003
Referência do Pacote de Gerenciamento do Microsoft System Management Server 2003


Tarefas mensais do SMS 2003

Além das tarefas realizadas diariamente e semanalmente, examine os dados das categorias a seguir mensalmente.

Alertas e eventos mais comuns

  • Alertas mais comuns
  • Eventos mais comuns
  • Alertas e eventos mais comuns por grupo de regras
  • Alertas e eventos mais comuns por componente do SMS 2003
  • Alertas e eventos mais comuns por recurso do SMS 2003

Desenvolva um plano de ação para reduzir estes números.

Monitoramento de registro posterior do SMS

  • Examine os relatórios relacionados às tendências dos registros posteriores em vários sistemas do site.

Tendências de registro posterior do SMS

  • Examine os relatórios relacionados com o registro posterior para assegurar que não haja uma tendência para cima de longo prazo no número de registros posteriores ou um nível inaceitável de registros posteriores que afetam os contratos de nível de serviço (SLAs) em um sistemas do site do SMS.

Tendências de desempenho do SMS: totais e taxas de processamento

  • Registros dos dados de descoberta
  • Inventário de hardware
  • Inventário de software
  • Medição de software
  • Mensagens de status

Desempenho geral do sistema

  • Uso de disco
  • Uso de memória
  • Uso de processador

Disponibilidade de serviços do SMS

  • SMS_EXECUTIVE
  • Serviço Host de Agente do SMS
  • Serviço do Cliente do SMS
  • SMS_REPORTING_POINT
  • SMS_SERVER_LOCATOR_POINT
  • SMS_SQL_MONITOR
  • SMS_SITE_COMPONENT_MANAGER

Disponibilidade do SMS

  • Execute os relatórios de disponibilidade do SMS 2003 para examinar a disponibilidade dos servidores do SMS e de seus componentes.

Consulte também

Tarefas diárias do SMS 2003
Tarefas semanais do SMS 2003
Tarefas do console do administrador do SMS 2003

Outros recursos

Executando tarefas de operações do Pacote de Gerenciamento do SMS 2003
Solução de problemas do Pacote de Gerenciamento do SMS 2003
Referência do Pacote de Gerenciamento do Microsoft System Management Server 2003


Tarefas do console do administrador do SMS 2003

As tarefas do Console do Administrador do SMS requerem a instalação do console do administrador do Microsoft Systems Management Server (SMS) 2003 SP2 ou posterior no mesmo computador do Console de Operações do Operations Manager 2007. Após a instalado do Console do Administrador do SMS, você deve fazer logoff e logon novamente no Windows para habilitar a funcionalidade da tarefa.

Tarefas do Pacote de Gerenciamento

Tarefa | Descrição
Console do Administrador do SMS | Abre o Console do Administrador do SMS direcionado ao computador selecionado no momento. Aplica-se aos computadores que hospedam a função do servidor do site do SMS.
Todas as mensagens de status do SMS | Solicita o servidor de site do computador, abre uma janela do MMC e executa uma consulta de mensagem de status para retornar todas as mensagens de status associadas ao computador selecionado no momento. Aplica-se a todos os sistemas.
Gerenciador de Serviços do SMS | Abre o Gerenciador de Serviços do SMS direcionado ao computador selecionado no momento. Aplica-se aos computadores que hospedam a função do servidor do site do SMS.
Explorer de Recursos do SMS | Solicita o servidor de site do computador, abre uma janela do MMC com o Explorer de Recursos do SMS exibindo os dados do computador selecionado no momento. Aplica-se a todos os sistemas.

Consulte também

Tarefas diárias do SMS 2003
Tarefas semanais do SMS 2003
Tarefas mensais do SMS 2003

Outros recursos

Executando tarefas de operações do Pacote de Gerenciamento do SMS 2003
Solução de problemas do Pacote de Gerenciamento do SMS 2003
Referência do Pacote de Gerenciamento do Microsoft System Management Server 2003


Solução de problemas do Pacote de Gerenciamento do SMS 2003

Existem várias medidas que podem ser tomadas para solucionar problemas do produto:

  • Verifique se o Operations Manager 2007 foi instalado corretamente.
  • Verifique se a configuração do Operations Manager 2007 foi definida corretamente.
  • Verifique se todos os sistemas do Microsoft® Systems Management Server (SMS) foram configurados com informações do Operations Manager.
  • Verifique se todos os computadores de bancos de dados do site do SMS e Provedor do SMS gerenciados possuem o agente do Operations Manager 2007 instalados e possuem o proxy para outros computadores habilitado.
  • Verifique se a importação do Pacote de Gerenciamento foi concluída e bem-sucedida.
  • Verifique se todas as entidades relevantes, como as regras e os alertas associados, estão habilitadas.
  • Verifique se os grupos de computadores estão preenchidos com os computadores corretos. Você pode usar os modos de exibição para realizar esta inspeção.
  • Verifique se não há alertas de falha de pulsação.
  • Verifique se o intervalo de pulsação está definido corretamente e se as regras são propagadas para o computador agente do Operations Manager 2007.
  • Verifique se os serviços dependentes, incluindo a Instrumentação de Gerenciamento do Windows (WMI), o Serviço de Publicação na World Wide Web, o Serviço de Administração dos Serviços de Informações da Internet (IIS), o Serviço de Transferência Inteligente em Segundo Plano (BITS) e o MSSQLServer, estão instalados e sendo executados corretamente nos sistemas do site do SMS 2003.
  • Verifique se não há regras desabilitadas automaticamente pelo Operations Manager 2007 devido ao acionamento excessivo, sintaxe incorreta ou scripts que são executados por muito tempo.
  • Verifique se todos os contadores de desempenho foram instalados corretamente.

Nesta seção

Problemas conhecidos do SMS2003

Consulte também

Cenários de monitoramento do Pacote de Gerenciamento
Implantando o Pacote de Gerenciamento do SMS 2003

Outros recursos

Visão geral do Pacote de Gerenciamento do System Management Server 2003
Executando tarefas de operações do Pacote de Gerenciamento do SMS 2003
Referência do Pacote de Gerenciamento do Microsoft System Management Server 2003


Problemas conhecidos do SMS2003

A lista a seguir mostra os problemas conhecidos do Pacote de Gerenciamento do Systems Management Server 2003 para o Operations Manager 2007.

O Modo de Manutenção e a exibição Topologia requerem o SMS 2003 SP3

O SMS pode interferir na instalação de softwares que não sejam da Microsoft que param o serviço WMI

Monitoramento do WMI

As tarefas do SMS só são executadas no contexto do usuário usado para instalar o console do SMS 2003 Administrator

O Pacote de Gerenciamento do SMS 2003 não consegue detectar o site secundário do SMS se o Console do Administrador do SMS estiver instalado no mesmo computador

O sistema reinicia

Script Monitor SMS Status Messages no SMS 2003

O script Monitor Site Summarizer no SMS 2003 é deslocado do intervalo do resumidor de status do sistema do site padrão

As regras de mensagem de status que monitoram a conectividade do remetente dependem do funcionamento do remetente

O monitoramento de BITS é desabilitado por padrão

O caminho do provedor de aplicativos é definido como C:\SMS\Logs por padrão, o que pode não ser válido em todos os servidores de site SMS

O Modo de Manutenção e a exibição Topologia requerem o SMS 2003 SP3

O SMS 2003 SP3 é necessário em servidores de site SMS 2003 para habilitar o modo de manutenção ou exibir a topologia do site com o Operations Manager 2007. Para obter mais informações, consulte Configuração suportada do SMS.

O SMS pode interferir na instalação de softwares que não sejam da Microsoft que param o serviço WMI

O Pacote de Gerenciamento do SMS 2003 pode interferir na instalação de softwares que não sejam da Microsoft que acessam o serviço WMI. A maioria dos scripts do Pacote de Gerenciamento usa o WMI para acessar o registro e pode reiniciar o serviço WMI. Se o serviço WMI estiver habilitado e puder ser iniciado, o Component Object Model (COM) reiniciará o WMI com êxito.

Se o software que não for da Microsoft parar, mas não desabilitar o WMI durante uma instalação ou atualização, o reinício automático do script WMI pode prejudicar a instalação do software que não seja da Microsoft. Isso pode ser um problema para o WMI ou as atualizações do provedor do WMI se o programa de instalação não desabilitar antes o serviço WMI. Esse problema se aplica a todos os clientes do WMI.

Monitoramento do WMI

  • As regras a seguir, baseadas no evento do sistema Windows NT®, registram eventos do Gerenciador de Controle de Serviço em caso de falhas de serviço inesperadas. Não há limitações de sistema operacional conhecidas para essas regras.
  • Falha de serviço dependente do SMS 2003: O serviço Instrumentação de Gerenciamento do Windows foi finalizado de maneira inesperada.
  • Falha de serviço dependente do SMS 2003: O serviço Instrumentação de Gerenciamento do Windows congelou ao ser iniciado.
  • Falha de serviço dependente do SMS 2003: O serviço Instrumentação de Gerenciamento do Windows não foi iniciado.
  • Falha de serviço dependente do SMS 2003: O serviço Instrumentação de Gerenciamento do Windows não pôde fazer logon.
  • Falha de serviço dependente do SMS 2003: O serviço Instrumentação de Gerenciamento do Windows depende de outro serviço que não foi iniciado ou não existe.

As tarefas do SMS só são executadas no contexto do usuário usado para instalar o console do SMS 2003 Administrator

Esse problema ocorre porque a variável de ambiente SMS_UI_PATH foi criada pela instalação do Console do Administrador do SMS como uma variável de ambiente do usuário, não como uma variável de ambiente do sistema. Para resolver esse problema, você pode copiar o nome e o valor de SMS_UI_PATH e definir as variáveis mencionadas como variáveis de ambiente do sistema, para que todos os operadores e administradores possam invocar tarefas sem erros.

O Pacote de Gerenciamento do Systems Management Server 2003 não consegue detectar o site secundário do SMS se o Console do Administrador do SMS estiver instalado no mesmo computador

A instalação de um console do Systems Management Server 2003 Administrator em um computador que também é um servidor de site secundário do SMS faz com que o Pacote de Gerenciamento do SMS 2003 não identifique o servidor como um servidor de site secundário do SMS.

Para resolver esse problema, ao instalar o Console do Administrador do SMS em um servidor de site secundário do SMS, você precisa alterar o valor do registro HKLM\SOFTWARE\Microsoft\SMS\Setup\Type de 4 para 2.

O sistema reinicia

Caso o sistema seja reiniciado, você pode receber apenas alguns alertas de interrupção de serviço. Não há eventos ou alertas que indiquem se o sistema foi reiniciado. A melhor solução para detectar um desligamento esperado ou inesperado do sistema é instalar o Pacote de Gerenciamento do sistema operacional básico Microsoft Windows Servers, que contém uma regra que o alerta quando o sistema é reiniciado. Outros métodos para determinar se o sistema foi reiniciado são verificar se houve comunicação de agentes nos logs do SMS, no log de eventos do Operations Manager 2007 NT, nos logs de eventos do Windows NT e nos eventos do Operations Manager 2007.

Script Monitor SMS Status Messages no SMS 2003

Quando a tabela de mensagens de status do SMS exceder 4.294.967.296 mensagens, a ID do registro é zerada. O script Monitor SMS Status Messages no SMS 2003 não tem um mecanismo para detectar quando a ID do registro foi zerada. No momento, o script procura somente a partir da ID do registro da última mensagem de status processada. Se a ID do registro for zerada, o Pacote de Gerenciamento não poderá detectar novas mensagens de status.

No servidor do site, anote o valor do registro Next Status Message Record ID na chave de registro HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\COMPONENTS\SMS_STATUS_MANAGER. Esse valor é a próxima ID de registro inserida na tabela SQL StatusMessages. Se esse valor for inferior ao valor de LastRecordID, isso significa que a tabela StatusMessages fez um auto-retorno e foi reiniciada. O script só processará mensagens novamente quando o valor do registro Next Status Message Record ID for maior do que o valor de LastRecordID no arquivo VarSet.

Você deve monitorar com freqüência a chave de registro HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\COMPONENTS\SMS_STATUS_MANAGER no servidor do site para ver a ID do registro da próxima mensagem de status. Empresas ou sites pequenos que estão muito abaixo na hierarquia SMS devem verificar essa chave de registro a cada dois ou três meses. Empresas ou sites de grande porte com vários sites filho devem verificar essa chave de registro todo mês. Se o valor se aproximar de 4.294.967.296, monitore-o com mais freqüência. Depois de a ID do registro ter sido zerada, você deve desbloquear o monitoramento de mensagens de status no computador que executa o servidor de banco de dados do site do SMS para o site. O local do banco de dados do site do SMS é designado por você durante a instalação do SMS.

Uma maneira de automatizar o monitoramento da chave de registro é criar um atributo de computador e um grupo de computadores para monitorar os computadores que estão se aproximando desse limite.

Para localizar todos os bancos de dados de site do SMS no seu grupo de configuração

  1. No Console de Operações, clique no botão Criação.
  2. No painel de resultados, clique com o botão direito do mouse em Microsoft Systems Management Server (SMS) 2003 e selecione Exibir Membros do Grupo.

Para desbloquear o monitoramento da mensagem de status

  1. No computador que hospeda a função de banco de dados do site do SMS, na pasta Temp do Windows, abra este arquivo de texto: SMS 2003 Monitor SMS Status Messages.VarSet. A entrada LastRecordID_[NomeBancoDadosSMS] é um valor da ID do registro que indica a última mensagem de status na tabela SQL StatusMessages processada pelo script.
  2. No computador que hospeda a função de banco de dados do site do SMS, altere o valor de LastRecordID_[NomeBancoDadosSMS], do site apropriado, no arquivo SMS 2003 Monitor SMS Status Messages.VarSet como sendo igual ao valor do registro da ID de registro Next Status Message menos um. Se o resultado for 4.294.967.296, defina o valor como zero e salve o arquivo.

O script Monitor Site Summarizer no SMS 2003 é deslocado do intervalo do resumidor de status do sistema do site padrão

O intervalo no qual o script Monitor Site System Summarizer no SMS 2003 é executado tem um deslocamento de 10 minutos em relação ao intervalo de sondagem do resumidor de status do sistema do site de uma hora a cada hora exata. Embora o Console do Administrador do SMS permita configurar a agenda do resumidor de status do sistema do site, ele não altera esse intervalo de sondagem, apenas o intervalo de outras tarefas de manutenção. O script Monitor Site System Summarizer no SMS 2003 é executado em um provedor de eventos temporizado, Schedule Every 60 Minutes Synchronize at 00:10. O período de deslocamento de 10 minutos dá tempo para que o resumidor de status do sistema do site conclua o ciclo. Se esse tempo for insuficiente, ele deve ser estendido; caso contrário, o script concluirá antes que o resumidor do sistema do site termine o ciclo. Isso pode resultar em um relatório de status do sistema do site antigo.

As regras de mensagem de status que monitoram a conectividade do remetente dependem do funcionamento do remetente

Se o remetente não consegue se conectar ao site pai, as mensagens de status não fluem para cima na hierarquia do SMS e o Pacote de Gerenciamento não gera um alerta sobre essas mensagens de status. Isso é muito importante no caso de sites secundários, que não têm o script Monitor Status Message do SMS 2003 em execução. As regras de mensagem de status a seguir que monitoram a conectividade do remetente dependem do funcionamento do remetente e estão desabilitadas por padrão:

  • Status do SMS 2003: O remetente não pode se conectar ao site remoto usando a LAN (Segurança Padrão).
  • Status do SMS 2003: O remetente não pode se conectar ao site remoto usando a conexão RAS.
  • Status do SMS 2003: O remetente não pode se conectar ao site remoto usando a LAN (Segurança Avançada).
Observação
Todas essas regras são desabilitadas por padrão. Para que essas regras funcionem, cada servidor de banco de dados de site do SMS ou, pelo menos, o site central, deve ser um computador gerenciado.

Um método de monitoramento paralelo foi fornecido e se baseia em um provedor de log de aplicativo, o log de remetente do SMS 2003. Essas regras são habilitadas por padrão. Se você desabilitar essas regras, tente habilitar as regras de mensagem de status complementares acima. Não habilite os dois conjuntos de regras, porque serão gerados alertas duplicados. Não há consolidação desses eventos ou regras de alertas que resolva a mensagem de status e a regra complementar ativa.

  • Componente do SMS 2003: O remetente não pode se conectar ao site remoto usando a LAN (Segurança Padrão).
  • Componente do SMS 2003: O remetente não pode se conectar ao site remoto usando a conexão RAS.
  • Componente do SMS 2003: O remetente não pode se conectar ao site remoto usando a LAN (Segurança Avançada).

Para que essas regras funcionem, você precisa modificá-las para que apontem para os arquivos de log do SMS. Além disso, cada servidor SMS com um remetente deve ser um computador gerenciado.

O monitoramento de BITS é desabilitado por padrão

Como o Serviço de Transferência Inteligente em Segundo Plano (BITS) é iniciado por demanda pelo SMS Advanced Client, a regra a seguir é desabilitada por padrão no Pacote de Gerenciamento do SMS 2003:

  • Serviço dependente do SMS 2003 executando: Serviço de Transferência Inteligente em Segundo Plano

Você deve habilitar essa regra se o serviço estiver configurado para iniciar automaticamente.

As regras a seguir são habilitadas por padrão para monitorar problemas com o serviço BITS e para relatar se o Host de Agente do SMS não puder iniciar o serviço BITS quando necessário:

  • Falha de serviço do SMS 2003: O Serviço de Transferência Inteligente em Segundo Plano terminou de maneira inesperada.
  • Falha de serviço do SMS 2003: O Serviço de Transferência Inteligente em Segundo Plano congelou ao ser iniciado.
  • Falha de serviço do SMS 2003: O Serviço de Transferência Inteligente em Segundo Plano não foi iniciado.
  • Falha de serviço do SMS 2003: O Serviço de Transferência Inteligente em Segundo Plano não pôde fazer logon.

Falha de serviço do SMS 2003: O Serviço de Transferência Inteligente em Segundo Plano depende de outro serviço que não foi iniciado ou não existe.

O caminho do provedor de aplicativos é definido como C:\SMS\Logs por padrão, o que pode não ser válido em todos os servidores de site SMS

Há quatro regras de componentes que usam o provedor de log de aplicativos para monitorar os arquivos de log do SMS em C:\SMS\Logs:

  • Componente do SMS 2003: O remetente não pode se conectar ao site remoto usando a LAN (Segurança Padrão).
  • Componente do SMS 2003: O remetente não pode se conectar ao site remoto usando a conexão RAS.
  • Componente do SMS 2003: O remetente não pode se conectar ao site remoto usando a LAN (Segurança Avançada).
  • Componente do SMS 2003: O Distribution Manager não processou um pacote.

As regras do remetente são habilitadas por padrão enquanto que a regra do Distribution Manager está desabilitada por padrão. Se você tiver instalado o SMS em uma unidade diferente da C ou modificado a pasta padrão na qual os logs são armazenados, será preciso modificar essa regra antes de habilitá-la. Se essa regra não for modificada para procurar os arquivos de log na pasta apropriada, o alerta não retornará as informações desejadas.

Ao modificar a regra para designar o caminho correto, você pode digitar um caminho para os arquivos de log ou criar uma variável de ambiente e modificar a regra para que use essa variável. Se você digitar um caminho, ele deverá funcionar em todos os servidores afetados por essa regra. Se tiver dois caminhos diferentes, um para os servidores de site principais e outro para os servidores de site secundários, execute estes procedimentos:

Para modificar o XML das regras de componentes para usarem um caminho alternativo para os arquivos de log

  1. No Console de Operações do Operations Manager 2007, clique no botão Criação, expanda Objetos do Pacote de Gerenciamento e clique em Regras.

  2. No painel Detalhes, clique com o botão direito do mouse na regra que deseja modificar e selecione Propriedades.

  3. Clique na guia Configuração.

  4. No painel Respostas, selecione a resposta cujo xml você deseja editar.

  5. Clique no botão Editar…. A caixa de diálogo GenerateAlert - Propriedades será aberta.

  6. Na guia Configuração da caixa de diálogo GenerateAlert - Propriedades, clique no botão Editar….

  7. Edite cadeia de caracteres do diretório como apropriado. Clique em OK e em Aplicar e, em seguida, clique em OK para salvar a alteração.

Consulte também

Configuração suportada do SMS

Outros recursos

Solução de problemas do Pacote de Gerenciamento do SMS 2003
Visão geral do Pacote de Gerenciamento do System Management Server 2003
Referência do Pacote de Gerenciamento do Microsoft System Management Server 2003


Referência do Pacote de Gerenciamento do Microsoft System Management Server 2003

Este material de referência fornece orientações para o Operations Manager 2007 e o System Management Server 2003

Nesta seção

Recursos adicionais para o Pacote de Gerenciamento do Microsoft System Management Server 2003

Sites e componentes do Pacote de Gerenciamento do SMS 2003

Grupos de computadores do SMS 2003

Grupo de regras do SMS 2003

Provedores do SMS 2003

Scripts do SMS 2003

Exibições do Microsoft SMS 2003

Diagramas do SMS 2003

Relatórios do SMS 2003

Consulte também

Cenários de monitoramento do Pacote de Gerenciamento
Implantando o Pacote de Gerenciamento do SMS 2003

Outros recursos

Visão geral do Pacote de Gerenciamento do System Management Server 2003
Executando tarefas de operações do Pacote de Gerenciamento do SMS 2003
Solução de problemas do Pacote de Gerenciamento do SMS 2003


Recursos adicionais para o Pacote de Gerenciamento do Microsoft System Management Server 2003

Os recursos a seguir estão disponíveis para o pacote de gerenciamento do Microsoft System Management Server 2003.

Microsoft Operations Manager 2007

Para acessar a documentação principal do produto Operations Manager 2007 na Internet e para obter as informações mais recentes sobre o System Center Operations Manager 2007, consulte a página da Web do produto Operations Manager 2007 (http://go.microsoft.com/fwlink/?LinkID=83259).

SMS 2003

Todas as informações necessárias para implantar e usar o SMS 2003 são fornecidas na documentação principal do produto, a ajuda do console do administrador do SMS, o glossário do SMS e a Biblioteca Online do SMS. A Biblioteca Online do SMS e a ajuda do console do administrador do SMS podem ser acessadas pelo console do administrador do SMS.

Biblioteca Online do SMS 2003

A Biblioteca Online do SMS fornece indicações para todas as informações de que você precisa para implantar e usar o SMS. Há duas maneiras de executar a Biblioteca Online do SMS depois de instalar o SMS 2003:

  • No menu Iniciar, clique em Programas, em Systems Management Server e, em seguida, selecione Biblioteca Online do SMS.
  • Clique com o botão direito do mouse em Biblioteca Online do SMS, na árvore do console do administrador do SMS e, em seguida, clique em Executar Biblioteca Online.

A Biblioteca Online inclui os seguintes itens:

  • "Notas de versão do SMS 2003", que contêm informações importantes sobre o SMS.
  • "Novidades desta versão do SMS", que descreve as diferenças entre esta versão do SMS 2003 e as anteriores.
  • Um link para a página da Web da documentação do produto SMS.
  • Links para páginas de download do Feature Pack de Gerenciamento de Dispositivos do SMS 2003 e o Feature Pack de Implantação do Sistema Operacional SMS 2003.

O SMS na Web

  • Para localizar documentos e informações técnicas sobre produtos relacionados, consulte o site do produto Microsoft Systems Management Server 2003. O site do SMS também fornece informações específicas sobre como usar o SMS com outros produtos Microsoft, como o Microsoft Windows® XP e o Microsoft Office XP.
  • Para obter links para pesquisar e baixar a documentação principal do produto SMS 2003, consulte a página da Web da documentação do produto Systems Management Server 2003.
  • A Microsoft mantém muitos grupos de notícias gratuitos nos quais você pode postar suas dúvidas e obter suporte grátis de outros usuários e, com freqüência, de membros da equipe do produto SMS. Visite a página da Web da comunidade do Systems Management Server para obter mais informações sobre grupos de notícias gratuitos.
  • Para obter artigos técnicos sobre procedimentos, perguntas freqüentes, transmissões via Web, grupos de notícias e muito mais, consulte a página da Web do suporte ao Systems Management Server.
  • Para pesquisar na Base de Dados de Conhecimento Microsoft e em outros recursos técnicos e obter respostas rápidas e precisas às suas dúvidas sobre o SMS, visite a página da Web de ajuda e suporte Microsoft. Você pode consultar a Base de Dados de Conhecimento para localizar um artigo sobre um problema específicos usando o número "Qxxxxxx" ou o número "xxxxxx" atribuído ao problema.

Enviando comentários

  • Para ajudar a equipe de documentação do SMS a fornecer o tipo de informações sobre o produto de que você mais precisa, dê-nos seus comentários e opiniões. Envie seus comentários sobre nossa documentação para Documentação do SMS.

Consulte também

Sites e componentes do Pacote de Gerenciamento do SMS 2003
Grupos de computadores do SMS 2003
Grupo de regras do SMS 2003
Provedores do SMS 2003
Scripts do SMS 2003
Exibições do Microsoft SMS 2003
Diagramas do SMS 2003
Relatórios do SMS 2003


Sites e componentes do Pacote de Gerenciamento do SMS 2003

Os componentes do SMS 2003 incluem o servidor de site central SMS, o banco de dados do site do SMS e o Console do Administrador do SMS. Normalmente, o servidor de site central SMS, o banco de dados do site do SMS e o Console do Administrador do SMS residem no mesmo servidor e cada função do sistema do site reside em um servidor dedicado. Um servidor e um banco de dados do site central, juntos com outras funções do sistema do site, compõem um único site do SMS. Um único site do SMS pode incluir várias funções duplicadas do sistema do site. Por exemplo, um único site pode incluir vários pontos de acesso do cliente (CAPs). Os sites do SMS 2003 podem ter várias camadas. Um único site do SMS não pode incluir algumas funções do servidor do site, por exemplo, um ponto localizador de servidor.

O Pacote de Gerenciamento do SMS 2003 foi desenvolvido para monitorar os componentes do servidor SMS. Este Pacote de Gerenciamento não foi desenvolvido para monitorar a funcionalidade do SMS em computadores cliente do SMS. No entanto, o Operations Manager 2007 pode ser usado para monitorar outros aplicativos que residem em um computador cliente do SMS.

Para obter mais informações sobre os componentes do SMS 2003, consulte a Biblioteca Online do SMS 2003. Para obter links para a documentação do SMS 2003, consulte a seção Recursos adicionais para o Pacote de Gerenciamento do Microsoft System Management Server 2003 neste guia.

Os principais componentes e funções do servidor incluem:

  • Ponto de acesso do cliente
  • Ponto de distribuição
  • Ponto de gerenciamento
  • Ponto localizador de servidor
  • Ponto de relatório
  • Servidor do site
  • Banco de dados do site
  • Remetentes
  • Cliente Avançado
  • Cliente Herdado
  • Provedor do SMS
  • Console do Administrador do SMS

Ponto de acesso do cliente

A função CAP é o ponto de contato entre os clientes herdados e o servidor do site do SMS. O CAP transmite todos os dados do Cliente Herdado para o servidor do site. Os computadores de Cliente Herdado entram em contato com o CAP para obter informações de gerenciamento do servidor do site do SMS. Um CAP serve somente a um site do SMS e é instalado por padrão no servidor do site. Além disso, o CAP:

  • Fornece arquivos e instruções de configuração específicas para o Cliente Herdado durante a instalação do cliente e quando são feitas alterações após a instalação do cliente.
  • Serve como o local no qual os computadores do Cliente Herdado verificam anúncios.
  • Recebe dados dos clientes herdados e os encaminha para o servidor do site do SMS. Por exemplo, quando um cliente conclui o inventário de hardware ou de software e cria um arquivo de dados de inventário, ele envia esses dados para o CAP. Todas as mensagens de status originadas no cliente são replicadas no CAP.

Ponto de distribuição

O ponto de distribuição armazena os arquivos de recurso do pacote SMS que os clientes do SMS usam durante a instalação de softwares distribuídos pelo SMS. Quando o administrador do SMS anuncia um programa, o anúncio e as informações do programa ficam disponíveis para os clientes por meio de um CAP para clientes herdados ou por meio de um ponto de gerenciamento para clientes avançados.

Quando o SMS é configurado, o servidor do site recebe automaticamente a regra de ponto de distribuição. O administrador do SMS pode habilitar o ponto de distribuição para usar o Serviço de Transferência Inteligente em Segundo Plano (BITS), que habilita o download incremental de arquivo de pacote nos clientes avançados.

Os clientes avançados usam o BITS para detectar automaticamente a capacidade de conexão da rede do cliente e ajustar as taxas de transferência de maneira eficiente. Isso é suportado somente em clientes que executam os sistemas operacionais Microsoft Windows 2000, Microsoft Windows XP Professional e Microsoft Windows Server™ 2003.

Ponto de gerenciamento

O ponto de gerenciamento é o ponto de contato principal entre os clientes avançados e o servidor do site do SMS. Um site do SMS tem apenas um ponto de gerenciamento padrão, embora seja possível configurar vários pontos de gerenciamento usando-se o Serviço de Balanceamento de Carga de Rede do Windows. De maneira semelhante à relação entre os CAPs e os clientes herdados, um ponto de gerenciamento:

  • Fornece detalhes de configuração de cliente específicos (também conhecidos como a diretiva de Cliente Avançado) para o cliente avançado após a instalação do cliente.
  • Serve como o local no qual os computadores do Cliente Avançado verificam anúncios.
  • Localiza pontos de distribuição para os clientes avançados.
  • Recebe informações sobre inventário, medição de software e status dos clientes avançados e as encaminha para o servidor do site do SMS.

Ponto localizador de servidor

O ponto localizador de servidor localiza os CAPs para os clientes herdados e os pontos de gerenciamento para os clientes avançados. O ponto localizador de servidor é mais usado na instalação do cliente. O ponto localizador de servidor:

  • Localiza um ponto de gerenciamento para o Cliente Avançado se este estiver configurado para atribuir o site do SMS automaticamente.
  • Fornece aos clientes avançados o local do ponto de gerenciamento durante a instalação do cliente iniciada por script durante o logon e durante uma instalação sem credenciais suficientes.
  • Fornece a atribuição do site do SMS para o Cliente Herdado e localiza CAPs durante a instalação do cliente iniciada por script durante o logon.

Ponto de relatório

Um ponto de relatório é um servidor que executa os Serviços de Informações da Internet (IIS) e hospeda o código do Visualizador de Relatórios e quaisquer relatórios complementares. Um ponto de relatório comunica-se somente com seu próprio servidor de banco de dados do site do SMS.

Cliente Avançado

O SMS 2003 resolve a necessidade de computação móvel com o Cliente Avançado. Esse componente suporta o conjunto de recursos completo do SMS, incluindo a distribuição de software, o gerenciamento de ativos e a solução de problemas remota. Você pode gerenciar usuários móveis e usuários de computadores de mesa sem fazer distinção entre eles. O Cliente Avançado usa uma tecnologia Windows chamada BITS para fornecer conectividade para todas as operações de gerenciamento.

Cliente Herdado

Você pode usar o Cliente Herdado se sua organização precisar gerenciar computadores que não atendem aos requisitos para dar suporte ao Cliente Avançado. Você pode habilitar, configurar e controlar estes métodos de instalação do Cliente Herdado:

  • Instalação do cliente iniciada por script durante o logon
  • Instalação push do cliente
  • Instalação manual do cliente

Provedor do SMS

O Provedor do SMS processa solicitações de dados feitas pelo banco de dados do site do SMS. A função Provedor do SMS é instalada no mesmo computador do servidor do site do SMS ou do banco de dados do site do SMS. Recomenda-se que você instale o Provedor do SMS e o banco de dados do site do SMS no servidor do site. O Provedor do SMS dá acesso aos dados para o Console do Administrador do SMS instalado no site.

Console do Administrador do SMS

O Console do Administrador do SMS é a interface do usuário por meio da qual o SMS é administrado. Essa interface usa um snap-in do Console de Gerenciamento Microsoft (MMC) fornecido com o software SMS. O Console do Administrador do SMS é instalado por padrão quando você instala um servidor de site principal. Ele também pode ser instalado em outros servidores ou estações de trabalho.

Consulte também

Recursos adicionais para o Pacote de Gerenciamento do Microsoft System Management Server 2003
Sites e componentes do Pacote de Gerenciamento do SMS 2003
Grupos de computadores do SMS 2003
Grupo de regras do SMS 2003
Provedores do SMS 2003
Scripts do SMS 2003
Exibições do Microsoft SMS 2003
Diagramas do SMS 2003
Relatórios do SMS 2003


Grupos de computadores do SMS 2003

O Pacote de Gerenciamento do SMS 2003 fornece estes grupos de computadores:

  • Consoles do administrador do Microsoft SMS 2003
  • Clientes avançados do Microsoft SMS 2003
  • Servidores de site central do Microsoft SMS 2003
  • Clientes do Microsoft SMS 2003
  • Servidores de ponto de acesso do cliente do Microsoft SMS 2003
  • Servidores de componentes baseados no IIS do Microsoft SMS 2003
  • Servidores de componentes baseados no Executivo SMS do Microsoft SMS 2003
  • Servidores de ponto de distribuição do Microsoft SMS 2003
  • Servidores de ponto de gerenciamento do Microsoft SMS 2003
  • Servidores de site principal do Microsoft SMS 2003
  • Provedores do Microsoft SMS 2003
  • Servidores de ponto de relatório do Microsoft SMS 2003
  • Servidores de site secundário do Microsoft SMS 2003
  • Servidores de remetente do Microsoft SMS 2003
  • Servidores de ponto localizador de servidor do Microsoft SMS 2003
  • Servidores do Microsoft SMS 2003
  • Servidores de site do Microsoft SMS 2003
  • Clientes herdados do Microsoft SMS 2003

Consulte também

Recursos adicionais para o Pacote de Gerenciamento do Microsoft System Management Server 2003
Sites e componentes do Pacote de Gerenciamento do SMS 2003
Grupos de computadores do SMS 2003
Grupo de regras do SMS 2003
Provedores do SMS 2003
Scripts do SMS 2003
Exibições do Microsoft SMS 2003
Diagramas do SMS 2003
Relatórios do SMS 2003


Grupo de regras do SMS 2003

Esta seção lista os grupos de regras e regras de eventos do Pacote de Gerenciamento do Systems Management Server (SMS) 2003 que geram eventos e alertas críticos. Consulte a Criação no Console de Operações do Operations Manager 2007 para examinar todas as regras do grupo.

Clientes do SMS - Avançado

O grupo de regras Clientes do SMS - Avançado contém regras para erros relacionados com os clientes avançados do SMS.

  • Serviço do SMS 2003 em execução: Host de Agente do SMS
  • Serviço dependente do SMS 2003 em execução: Serviço de Transferência Inteligente em Segundo Plano
  • Serviço dependente do SMS 2003 em execução: Instrumentação de Gerenciamento do Windows

Pontos de Acesso do Cliente do SMS

O grupo de regras Pontos de Acesso do Cliente do SMS contém regras para erros relacionados com os pontos de acesso do cliente do SMS.

  • Serviço do SMS 2003 em execução: SMS_EXECUTIVE

Pontos de Gerenciamento do SMS

O grupo de regras Ponto de Gerenciamento do SMS contém regras para erros relacionados com os pontos de gerenciamento do SMS.

  • Serviço do SMS 2003 em execução: Host de Agente do SMS
  • Serviço do SMS 2003 em execução: SMS_EXECUTIVE
  • Serviço dependente do SMS 2003 em execução: Serviço de Publicação na World Wide Web
  • Serviço dependente do SMS 2003 em execução: Serviço de Administração do IIS
  • Integridade do Ponto de Gerenciamento do SMS 2003: Estado
  • Limite de Desempenho do SMS 2003: Registros posteriores de DDRs nos pontos de gerenciamento > 10.000 em 3 horas
  • Limite de Desempenho do SMS 2003: Registros posteriores de inventário de hardware nos pontos de gerenciamento > 10.000 em 3 horas
  • Limite de Desempenho do SMS 2003: Registros posteriores de inventário de software nos pontos de gerenciamento > 10.000 em 3 horas
  • Limite de Desempenho do SMS 2003: Registros posteriores de coleta de arquivos nos pontos de gerenciamento > 10.000 em 3 horas
  • Limite de Desempenho do SMS 2003: Registros posteriores de gerenciador de retransmissão nos pontos de gerenciamento > 10.000 em 3 horas
  • Limite de Desempenho do SMS 2003: Registros posteriores de status nos pontos de gerenciamento > 10.000 em 3 horas
  • Limite de Desempenho do SMS 2003: Processo - % tempo de processador (ccmexec) > 95 em 3 horas

Provedores do SMS

O grupo de regras Provedores do SMS contém regras para erros relacionados com o componente Provedores do SMS 2003.

  • Serviço dependente do SMS 2003 em execução: Instrumentação de Gerenciamento do Windows

Pontos de Relatório do SMS

O grupo de regras SMS Reporting Point contém regras para erros relacionados com os pontos de relatório do SMS.

  • Serviço do SMS 2003 em execução: SMS_REPORTING_POINT
  • Serviço dependente do SMS 2003 em execução: Serviço de Publicação na World Wide Web
  • Serviço dependente do SMS 2003 em execução: Serviço de Administração do IIS

Servidores de Remetentes do SMS

O grupo de regras Servidores de Remetentes do SMS contém regras para erros relacionados aos Servidores de Remetentes do SMS.

  • Serviço do SMS 2003 em execução: SMS_EXECUTIVE

Pontos de Localizador do Servidor do SMS

O grupo de regras Ponto de Localizador do Servidor SMS contém regras para erros relacionados com os pontos de localizador do servidor do SMS.

  • Serviço dependente do SMS 2003 em execução: Serviço de Publicação na World Wide Web
  • Serviço dependente do SMS 2003 em execução: Serviço de Administração do IIS
  • Serviço do SMS 2003 em execução: SMS_SERVER_LOCATOR_POINT

Servidor do SMS - Comum

O grupo de regras Servidor do SMS - Comum contém regras para erros relacionados com todos os servidores do SMS.

  • Limite de Desempenho do SMS 2003: Arquivo de paginação - % uso > 98 em 3 horas
  • Limite de Desempenho do SMS 2003: Processo - % tempo de processador (_Total) > 95 em 3 horas

Servidores do SMS Baseados no SMS Executive

O grupo de regras Servidores do SMS Baseados no SMS Executive contém regras para erros gerados em qualquer servidor do site que execute o serviço SMS Executive.

  • Limite de Desempenho do SMS 2003: Processo - % tempo de processador (smsexec) > 95 em 3 horas

Servidores de Banco de Dados do Site do SMS

O grupo de regras Servidores de Banco de Dados do Site do SMS contém regras para erros relacionados ao servidor de banco de dados do site do SMS.

  • Serviço do SMS 2003 em execução: SMS_SQL_MONITOR
  • Serviço dependente do SMS 2003 em execução: MSSQLSERVER
  • Limite de Desempenho do SMS 2003: Conexões SQL do SMS > 500 em 2 horas

Servidores do Site do SMS - Comum

O grupo de regras Servidores do Site do SMS - Comum contém regras para erros relacionados com todos os servidores do site do SMS.

  • Serviço do SMS 2003 em execução: SMS_SITE_COMPONENT_MANAGER
  • Serviço do SMS 2003 em execução: SMS_EXECUTIVE
  • Limite de Desempenho do SMS 2003: Registro posterior dos trabalhos do agendador do servidor do site > 10.000 em 3 horas
  • Limite de Desempenho do SMS 2003: Registro posterior das solicitações de envio do agendador do servidor do site > 10.000 em 3 horas
  • Limite de Desempenho do SMS 2003: Registro posterior do SWM do servidor do site > 10.000 em 3 horas
  • Limite de Desempenho do SMS 2003: Registro posterior do SINV do servidor do site > 10.000 em 3 horas
  • Limite de Desempenho do SMS 2003: Registro posterior do HINV do servidor do site > 10.000 em 3 horas
  • Limite de Desempenho do SMS 2003: Registro posterior do DDR do servidor do site > 10.000 em 3 horas

Servidores de Banco de Dados do Site do SMS - Principal

O grupo de regras Servidores do Site do SMS - Principal contém regras para erros relacionados com todos os servidores do site do SMS.

  • Limite de Desempenho do SMS 2003: Registro posterior do SINV do servidor do site > 10.000 em 3 horas
  • Limite de Desempenho do SMS 2003: Registro posterior do HINV do servidor do site > 10.000 em 3 horas

Consulte também

Recursos adicionais para o Pacote de Gerenciamento do Microsoft System Management Server 2003
Sites e componentes do Pacote de Gerenciamento do SMS 2003
Grupos de computadores do SMS 2003
Grupo de regras do SMS 2003
Provedores do SMS 2003
Scripts do SMS 2003
Exibições do Microsoft SMS 2003
Diagramas do SMS 2003
Relatórios do SMS 2003


Provedores do SMS 2003

Os tipos de provedores de dados usados pelo Pacote de Gerenciamento do SMS 2003 são os seguintes:

  • Log do aplicativo
  • Evento de tempo limite
  • Contador de Desempenho do Windows NT

Consulte também

Recursos adicionais para o Pacote de Gerenciamento do Microsoft System Management Server 2003
Sites e componentes do Pacote de Gerenciamento do SMS 2003
Grupos de computadores do SMS 2003
Grupo de regras do SMS 2003
Scripts do SMS 2003
Exibições do Microsoft SMS 2003
Diagramas do SMS 2003
Relatórios do SMS 2003


Scripts do SMS 2003

O SMS 2003 Management Pack contém scripts do Operations Manager 2007 que executam automaticamente no agente e scripts que precisam ser executados por um administrador. Há informações adicionais sobre alguns desses scripts a seguir nesta seção.

Os scripts a seguir são executados pelo agente Operations Manager 2007 automaticamente:

  • SMS 2003 Monitor SMS Status Messages
  • SMS 2003 Monitor Site System Summarizer
  • SMS 2003 Service Discovery – Cliente
  • SMS 2003 Service Discovery – Servidor
  • SMS 2003 Site Backup Event Suppression
  • SMS 2003 Monitor Management Point Health
  • SMS 2003: Monitor Management Point Availability
  • SMS 2003 Site Hierarchy Discovery
  • SMS 2003 Monitor SMS Inbox
  • SMS 2003 Monitor SMS Executive Crash Dumps

SMS 2003 Monitor SMS Status Messages

Muitos problemas no SMS são detectados e informados internamente por meio do Sistema de Status do SMS. Mensagens de status são geradas por componentes do SMS que pertencem a condições de interesse de um administrador de SMS.

As mensagens de status fluem no banco de dados de um site do SMS e também na hierarquia do site para o banco de dados do site pai. É possível monitorar o sistema de status do SMS por site, simplesmente consultando a tabela de mensagens de status do SMS de um determinado banco de dados do site.

Um conjunto de mensagens de status foi escolhido para monitoramento que reflete os principais eventos para administradores do SMS. Quando uma dessas mensagens é encontrada no banco de dados, um alerta é gerado.

Este script faz o seguinte:

  • Verifica se ele está sendo executado no modo gerenciado sem agente. Se for o caso, o script será encerrado sem fazer mais nada.
  • Inicializa variáveis globais.
  • Abre e lê o RecordID da última mensagem de status processada para cada banco de dados do site do SMS que está sendo monitorado do arquivo VarSet do SMS 2003 Monitor SMS Status Messages.
  • Processa as mensagens de status encontradas em cada Banco de Dados do Site do SMS no computador local.
  • Grava o RecordID da última mensagem de status processada para cada Banco de Dados do Site do SMS que está sendo monitorado no arquivo VarSet do SMS 2003 Monitor SMS Status Messages e fecha o arquivo.

O script SMS 2003 Monitor SMS Status Messages gera eventos com uma Identificação de Evento definida para a Identificação da Mensagem de Status do SMS sobre a qual está sendo informada. A Tabela S.1 descreve o formato do evento gerado.

Tabela S.1 Formato de Eventos Gerados pelo Script SMS 2003 Monitor SMS Status Messages

Parâmetro | Descrição
EventType | Sucesso, Erro, Aviso ou Informação, dependendo da gravidade da mensagem de status do SMS
EventNumber | Identificação da Mensagem de Status do SMS
Category | Código do site do SMS
LoggingDomain | Domínio de recurso do computador
LoggingComputer | Nome NetBIOS do computador
Parameter1 | Nome NetBIOS do computador
Parameter2 | Nome do módulo do SMS—por exemplo, SMS Server
Parameter3 | Nome do componente do SMS
Parameter4 | Identificação da Mensagem do SMS
Parameter5 | Código de erro do Win32
Parameter6 | Código pai ou de nível superior do site
Parameter7 | RecordID da mensagem de status na Tabela de Mensagem de Status do SMS
Descrição | "Uma nova mensagem de status do SMS monitorado na máquina <NetBIOS Name> do componente <Component Name> com identificação de mensagem <Message ID> foi encontrada no banco de dados do site <Site Code>.”

O script SMS 2003 Monitor SMS Status Messages também informa erros de script por meio do número 1102 da Identificação da Mensagem de Status:

EventType= Aviso

EventNumber= 1102

Descrição = O script SMS 2003 Monitor SMS Status Messages, executado com a regra de processamento <ScriptProcessingRuleName>, encontrou um erro no tempo de execução. A mensagem de erro conterá o texto “Failed to <ErrorDescription>.”

Todas as regras de evento de monitoramento da mensagem de status do SMS 2003 começam com a frase “Status do SMS 2003:” e estão localizadas no grupo de regras Servidores do Banco de Dados do Site do SMS.

  • Status do SMS 2003: Monitoramento de Mensagens

Status do SMS 2003: O Monitoramento de Mensagens aciona o script usando a Programação do SMS 2003 a cada 30 minutos, sincronizado no provedor de evento de tempo de 00:02. Informações resumidas são fornecidas na página de propriedades de Conhecimento da regra.

  • Status do SMS 2003: Erro do script

Status do SMS 2003: Erro do script monitora e alerta sobre qualquer evento de erro de script que possa ser gerado. Só há um evento de erro de script, número 1102, que informa sobre todos os erros de script. Informações sobre resolução do alerta são fornecidas na página de propriedades de Conhecimento da regra.

  • Status do SMS 2003: <status message name>

Status do SMS 2003: <nome da mensagem de status> monitora e alerta sobre eventos de mensagem de status específicos. Informações sobre resolução do alerta são fornecidas na página de propriedades de Conhecimento da regra.

Todos os alertas têm uma descrição do evento no seguinte formato, onde $Descrição$ é a descrição do evento:

$Registro em Log do Computador$ - "Nome da Regra". $Descrição$

O arquivo VarSet do SMS 2003 Monitor SMS Status Messages é usado para que o RecordID da última mensagem de status processada continue por banco de dados do site. O arquivo VarSet encontra-se no diretório Windows\Temp. É um arquivo limitado por tab com o seguinte formato:

Código da cópia
LastRecordID_DBNameRecordID#

Por exemplo, LastRecordID_SMS_FLA, com um RecordID de 477860 indicaria que o último RecordID processado do banco de dados do SMS_FLA tinha o número 477860.

Ao atualizar o pacote de gerenciamento a partir de uma versão anterior, você encontrará o seguinte no arquivo VarSet do SMS 2003 Monitor SMS Status Messages:

Código da cópia
LastRecordID476743
LastRecordID_SMS_FLA477860

A primeira linha, que não contém um nome de banco de dados, indica a versão original do monitoramento da mensagem de status que não suporta monitoramento de vários bancos de dados. A segunda linha, que contém um nome de banco de dados, SMS_FLA, indica a versão atual do monitoramento da mensagem de status que suporta monitoramento de vários bancos de dados.

Nenhuma ação será realizada para utilizar a primeira linha de dados, porque, no caso de vários bancos de dados do site, é difícil determinar a qual banco de dados ela corresponde. A primeira linha de dados não é removida do arquivo VarSet, porque ela pode ser importante para avaliar as novas alterações e garantir que o monitoramento de mensagens de status comece com o RecordID correto após a atualização.

SMS 2003 Monitor Site System Summarizer

Site System Summarizer

O Site System Status Summarizer é um thread de componente do serviço SMS Executive que mantém o status em todos os sistemas do site do SMS. Por padrão, ele pesquisa uma vez a cada hora, na hora, o status atual. Esse intervalo de pesquisa é definido no Arquivo de Controle do Site do SMS. É recomendado que o intervalo de pesquisa não seja alterado. O status é mantido em uma tabela no banco de dados do site do SMS.

Status DownSince do Sistema do Site

O Site System Status Summarizer assume que um sistema do site está desativado quando não pode fazer contato com ele durante um de seus intervalos de pesquisa. Isso pode ocorrer devido a um dos seguintes fatores:

  • O sistema do site não está ativado, não está conectado à rede ou não está funcionando apropriadamente.
  • O SMS Site System Status Summarizer não tem uma conexão, porque não há conexões disponíveis.
  • O SMS Site System Status Summarizer não tem direito de acesso suficiente para se conectar ao sistema do site.
  • Problemas de rede estão impedindo que o SMS Site System Status Summarizer se conecte com o sistema do site.
  • O sistema do site foi permanentemente retirado de serviço.

Disponibilidade Baseada no Site System Status Summarizer

O status do Site System Status Summarizer é usado para relatórios de disponibilidade pelo Script SMS 2003 Server Availability e pelo Relatório SMS 2003 Server Availability. As medições de disponibilidade do SMS Server utilizam o valor de registro DownSince para determinar se o servidor está ou não disponível.

Limitações da Disponibilidade Baseada no Site System Status Summarizer

Esta seção explica as limitações de uso do status do Site System Summarizer para relatórios de disponibilidade pelo Script SMS 2003 Server Availability e pelo Relatório SMS 2003 Server Availability. As medições de disponibilidade do SMS Server utilizam o valor de registro "DownSince" para determinar se o servidor está ou não disponível.

O monitoramento da disponibilidade baseada no Site System Status Summarizer tem as seguintes limitações:

  • O interavalo de pesquisa do Site System Summarizer é de uma hora. Esse intervalo permite que haja tempo suficiente para que o Site System Status Summarizer pesquise todos os sistemas do site. Por motivos de desempenho, o intervalo não pode ser alterado. O intervalo de tempo limite do resumidor é controlado pela propriedade Startup Schedule no Arquivo de Controle do Site, e não pela propriedade Wakeup Interval. Isso significa que alterar o valor padrão 60 da propriedade Wakeup Interval não surte efeito. Além disso, alterar Startup Schedule não surte efeito. Por padrão, ele é definido para cada 15 minutos, e o Site System Status Summarizer pesquisa os sistemas do site uma vez por hora, na hora, independentemente de como o Startup Schedule é definido.
  • A metodologia de disponibilidade considera um site disponível somente se ocorrerem dois eventos sucessivos de SMS 2003 Site System Summarizer: Site System is possibly down em um período de duas horas. Isso foi projetado para dar conta de interrupções de rede temporárias. O que significa que a sua disponibilidade é avaliada em interrupções de serviço de duas horas, mesmo que o site tenha estado indisponível por pouco tempo.
  • O SMS pode ficar indisponível de muitas maneiras que o Site System Status Summarizer não monitora. Por exemplo, o Site System Status Summarizer não considera o SMS indisponível se os serviços do SMS não estiverem funcionando ou se o banco de dados do site do SMS estiver indisponível, como quando o serviço do SQL Server é interrompido.
  • Os dados de disponibilidade sofrem o impacto de computadores que hospedam várias regras de servidor do SMS. O tempo de inatividade é calculado com base em alertas gerados para um sistema do site que está desativado. Um único alerta tem o valor de um tempo de inatividade de duas horas. O Site System Status Summarizer grava no banco de dados o status "DownSince" atual de cada objeto do site e função de sistema do site hospedado em um computador, na tabela Site System Status Summarizer.

O script de monitoramento Site System Status Summarizer examina cada função do sistema do site na tabela Site System Status Summarizer. Se um sistema do site estiver marcado como desativado, ele produzirá um evento. Um alerta é gerado posteriormente com base nesse evento. Várias funções podem gerar vários alertas, o que criará durações de inatividade estendidas. Isso pode ser refletido como percentuais de disponibilidade negativos, dependendo do intervalo de interesse.

Cada função do servidor do SMS, exceto de um ponto de distribuição do SMS, estabelece duas funções de servidor do SMS por padrão, uma para a função específica e outra para o servidor de componente do SMS. Por exemplo, no caso de um sistema do site hospedar um ponto do localizador do servidor e um ponto de relatório, se o servidor ficar offline por mais de duas horas (dois intervalos de pesquisa do Site System Status Summarizer), o Site System Status Summarizer marcará essas duas funções e suas funções de servidor do componentes do SMS como desativadas.

Entretanto, somente três alertas, um para cada função do servidor e um para o servidor de componente físico que hospeda duas funções do servidor, seriam gerados por intervalo de pesquisa em um período de duas horas. Isso produziria um resultado de disponibilidade negativo, porque seis horas seriam marcadas como indisponíveis para o período de duas horas.

  • O plano de 60 minutos, com diferença de 10 minutos, foi definido como padrão para que o script SMS 2003 Monitor Site System Summarizer fosse executado 10 minutos após o começo do intervalo de pesquisa de 1 hora do Site System Status Summarizer. Se o resumidor precisar de mais de 10 minutos para concluir o ciclo, a diferença do provedor de evento com tempo deve ser aumentado de maneira apropriada. Caso contrário, as mensagens de status do sistema do site mais recentes serão perdidas.

SMS 2003: Monitor Management Point Availability

O script SMS 2003 Monitor Management Point Availability suporta o Relatório de Disponibilidade de Ponto de Gerenciamento. A disponibilidade baseia-se no estado de integridade de um ponto de gerenciamento e influencia o seguinte valor do estado de integridade encontrado no registro:

DWORD valor HKEY_LOCAL_MACHINE\Microsoft\SMS\MP\MPHealthState

Com base em um intervalo configurável de plano e relatórios, o script lê e informa, por meio de um evento do Operations Manager 2007, o tempo de duração do estado não íntegro (valor de registro 1, não 0).

Esses eventos de dados de disponibilidade são gravados nos bancos de dados OperationsManager e OperationsManagerDW. Um relatório do Operations Manager 2007 pode ser executado e exibir o tempo total em que o Ponto de Gerenciamento ficou desativado durante um intervalo especificado junto com um percentual de disponibilidade.

O valor de registro MPHealthState é mantido pelo Gerenciador de Controle do MP. Ele é atualizado a cada seis minutos.

Esse script realiza as seguintes ações:

  • Verifica se ele está sendo executado no modo gerenciado sem agente. Se for o caso, o script será encerrado sem fazer mais nada. O script usa um arquivo VarSet local para continuar com as variáveis, de maneira que o agente Operations Manager 2007 seja instalado.
  • Inicializa variáveis globais.
  • Obtém os parâmetros de entrada ScheduledInterval e ReportingInterval, em minutos.
  • Verifica se os parâmetros de entrada não estão vazios, com valor 0 ou negativo. Se estiverem, um evento de erro de script será gerado, indicando que um valor não válido foi especificado. O script também verifica se o valor ReportingInterval não é menor que o valor ScheduledInterval. Se for, um evento de erro de script será gerado, indicando que ReportingInterval não pode ser menor que ScheduledInterval. Os dois valores implementam um tipo de Lng e têm um valor máximo de 2147483647 (2G -1).
  • Abre e copia o conteúdo do arquivo VarSet do SMS 2003 Monitor Management Point Availability para uma coleção local. Se o arquivo não existir, nenhum evento de erro de script será gerado. Se o arquivo existir, mas não puder ser aberto, um evento de erro de script será gerado.
  • Verifica a disponibilidade do Ponto de Gerenciamento.
    • Se a versão do SMS atual for menor que 2.50.3067.0000, o script será encerrado sem erro gerado, porque o valor do registro MPHealthState não está presente. O arquivo de log da Resposta do Agente, AgentResponses-Configuration Group Name.log, conterá a sentença "Monitoring Management Point health is not supported on this SMS build." O registro em log é habilitado ao configurar o valor DWORD do EnableActiveDebugging DWORD, na chave HKEY_LOCAL_MACHINE\SOFTWARE\Mission Critical Software\OperationsManager, como 1.
    • Obtém o Estado de Integridade do Ponto de Gerenciamento atual do valor DWORD do registro HKEY_LOCAL_MACHINE\Microsoft\SMS\MP\MPHealthState. Se o valor não puder ser obtido, o script será encerrado sem gerar erro, porque o Gerenciador de Controle do MP ainda não o criou.
    • Obtém a Data e a Hora Inicial da coleção VarSet. Se esta for a primeira execução do script e o início de um novo período de relatórios, não há entrada. O script inicializa a duração e a data inicial, na coleção VarSet, antes de ser encerrado sem gerar erro. Ele define a duração como 0 e a data inicial como a data e hora atuais.
    • Para o intervalo de relatórios atual, se o valor de registro MPHealthState é 1, o script incrementa a duração indisponível na coleção VarSet, com base no intervalo do plano especificado.
    • Informa, criando um evento de dados de disponibilidade, se já foi decorrido o intervalo de relatórios e se o ponto de gerenciamento ficou indisponível. O script redefine a duração com 0 e a data inicial na coleção VarSet com a hora local atual para o próximo período de relatórios.
    • Se ocorrer um erro durante a verificação de disponibilidade do Ponto de Gerenciamento, um erro de script será gerado.

Número do Evento = 1102

Tipo de Evento = Aviso

Mensagem = "O script ‘SMS 2003 Monitor Management Availability' executado com a regra de processamento <ProcessingRuleName> encontrou um erro no tempo de execução." CrLf "Falhou ao verificar a disponibilidade do Ponto de Gerenciamento.” <ErrorString>

  • Grava o conteúdo da coleção VarSet no arquivo VarSet do SMS 2003 Monitor Management Point Availability e fecha o arquivo. Se o arquivo não existir, será criado. Se nenhuma variável VarSet foi definida, nenhuma entrada para elas aparecerá no arquivo. Se ocorrer um erro ao gravar o arquivo, o script produzirá um erro de script.

SMS 2003: Monitor SMS Inbox

O SMS faz a maioria de suas principais atividades do lado do servidor ao ler de e gravar em arquivos nas suas caixas de entrada. Quando as caixas de entrada do SMS ficam estranhamente cheias, isso é uma forte indicação de que o processamento do SMS está ficando para trás. Isso pode ocorrer por vários motivos, incluindo, mas não se restringindo a, arquivos inválidos, processos interrompidos, falta de espaço em disco ou nível de atividade de distribuição de software incomum. Tais problemas são bem raros, mas sérios para clientes com um grande número de sites.

Vários contadores de desempenho para caixas postais do SMS medem o número de itens enfileirados pelo componente de serviço, e não o número real de itens aguardando para serem processados no disco. O componente de serviço do SMS atualizará o contador de desempenho após trabalhar por meio de sua fila atual. Isso pode fazer com que a atualização dos contadores de desempenho seja pouco freqüente, impedindo a detecção oportuna de importantes registros posteriores. O novo script SMS 2003: Monitor SMS Inbox adiciona monitoramento direto por meio da contagem de arquivos em caixas de entrada de servidores SMS importantes e alerta o administrador por meio do Operations Manager 2007, quando o número de arquivos em uma determinada caixa de entrada excede um valor de limite configurável pelo usuário.

Todas as regras encontram-se no grupo de regras de processamento do SMS Site Servers – Comumque direciona essas regras em sites centrais, primários e secundários. O limite passado para o script pode ser configurado por meio de uma substituição.

Devido a considerações de desempenho, essas regras não se direcionam a pontos de gerenciamento ou qualquer outra função do sistema do site do SMS.

Agenda e Configuração Opcional

Para minimizar o impacto do desempenho do monitoramento da caixa de entrada, as regras pertinentes serão sincronizadas para execução uma vez por dia. As regras são alternadas em intervalos de 15 minutos, começando à 1:00, de maneira que somente uma regra seja executada por vez. Por exemplo, a primeira regra conta os arquivos presentes na primeira caixa de entrada à 1:00. A próxima regra conta os arquivos presentes na segunda caixa de entrada à 1:15 etc., até que todas as caixas de entrada tenham sido contadas.

Você pode modificar essa agenda, seguindo as etapas usuais na execução do script de regras de agendamento no Operations Manager 2007. Nenhuma configuração inicial é necessária para ativar este recurso. A seguir estão as alterações de configuração opcional que você pode realizar:

  • Alterar o valor do limite padrão para cada caixa de entrada.
  • Alterar a agenda para as regras de caixa de entrada individual.

Essas alterações de configuração opcional podem ser realizadas por meio das etapas usuais de configuração de regras de evento de limite em qualquer pacote de gerenciamento.

Alertas e Valores de Limite

Um alerta é gerado sempre que o valor de limite configurado para uma regra de caixa de entrada específica é alcançado quando a regra de monitoramento é processada. Um alerta de erro de script é gerado sempre que o script encontra um valor de limite não válido ou um erro tentando monitorar a contagem de arquivos em cada caixa de entrada.

Para editar os valores de limite de desempenho

  1. No console do Administrador do Operations Manager 2007, clique em Authoring.

  2. No painel Authoring, navegue em Authoring / Management Pack Objects / Monitors.

  3. No painel Monitors, altere o escopo para SMS server.

  4. Navegue em SMS Server / Entity Health / MOM 2005 Computer Role Health e expanda a função do servidor para ser editada.

    • DB - Servidor do banco de dados
    • MP - Servidor do ponto de gerenciamento
    • SS - Servidor do site

  5. Clique duas vezes na regra do monitor de limite de desempenho para ser editada. A caixa de diálogo Performance Threshold Properties é aberta.

  6. Selecione a guia Configuration.

  7. Clique em Edit…. A caixa de diálogo Xml Configuration é aberta.

  8. No texto de XML, edite o valor do limite a ser modificado.

    • Especifique o <ValueExpression> aninhado no <CriticalErrorExpression> para alterar o limite de erro crítico.
    • Especifique o <ValueExpression> aninhado no <WarningExpression> para alterar o limite de aviso.

  9. Clique em OK. Clique em OK. Os valores de limite modificados são distribuídos para os servidores.

O valor de limite padrão para cada regra de monitoramento de caixa de entrada é definido como 10.000. Você deve definir valores de limite para o parâmetro FileCountThreshold do script SMS 2003: Monitor SMS Inbox conforme apropriado no seu ambiente específico. Valores de limite válidos variam de 1 a 2147483647 (0x7FFFFFFF), inclusive. Valores de limite inválidos são zero (0) ou números maiores que 2147483647, já que produzirão números negativos no intervalo de 32 bits.

Para obter uma descrição de pastas de caixa de entrada e como elas são usadas no Systems Management Server, consulte o tópico relevante em Microsoft Help and Support.

Script SMS 2003 Monitor SMS Executive Crash Dumps

Este script encontra-se na pasta Scripts do console do Administrador do SMS e se chama SMS 2003 Monitor SMS Executive Crash Dumps. As seguintes ações são realizadas por esse script:

  • Determina se o computador de destino está funcionando no modo sem agente. Se for o caso, o script será encerrado sem fazer mais nada. Esse script usa um arquivo VarSet local para continuar com as variáveis, de maneira que o agente Operations Manager 2007 seja instalado em todos os computadores de destino.
  • Abre e lê o conteúdo do arquivo VarSet do SMS 2003 Monitor SMS Executive Crash Dumps local em uma coleção. Se o arquivo não existir, nenhum evento de erro de script será gerado. Se o arquivo existir, mas não puder ser aberto, um evento de erro de script será gerado, com uma mensagem que contém o seguinte texto:

Failed to load script variables.

  • Verifica se um novo despejo de memória ocorreu desde a última verificação. Se for o caso, o script produzirá um evento para informar o novo despejo de memória. Para gerar o evento de erro de script, o script faz o seguinte:
    • Obtém o Diretório de Instalação do SMS no registro na chave de Identificação do SMS, valor de registro "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\Identification\ Installation Directory". Se o caminho não puder ser obtido, o script produzirá uma mensagem de evento de erro de script com o texto a seguir e será encerrado:

Failed to read registry value.

  • Constrói o caminho completo do diretório CrashDumps anexando "\Logs\CrashDumps" ao Diretório de Instalação do SMS recuperado.
  • Verifica se o diretório CrashDumps existe. Se não existir, o script registra em log que a existência da pasta não pôde ser verificada e encerra sem fazer mais nada. O arquivo de log de Resposta do Agente, AgentResponses-Configuration Group Name.log, conterá a frase:

Failed to verify existence of crash dump directory: <CrashDumpsPath>.

O registro em log é habilitado ao configurar o valor DWORD do EnableActiveDebugging na chave HKEY_LOCAL_MACHINE\SOFTWARE\Mission Critical Software\OperationsManager como 1.

  • Obtém a última data de criação da pasta de despejo de memória da coleção VarSet.
  • Verifica se novos despejos de memória foram criados e funciona somente no mais recente. Para determinar qual é o mais recente, é usada a data de criação da pasta salva do último despejo de memória, se disponível. A comparação de data e hora baseia-se na criação de pasta para uma resolução de um segundo.
  • Se ocorreu um novo despejo de memória ou se for a primeira vez que o script é executado, o script registra o log e cria o evento 1710, especificando uma nova pasta e caminho de despejo de memória. O script salva a data da criação da pasta do despejo de memória na coleção VarSet. Se não ocorreu um despejo de memória, isso é registrado no log.
  • Grava o conteúdo da coleção VarSet no arquivo VarSet do SMS 2003 Monitor SMS Executive Crash Dumps e fecha o arquivo. Se o arquivo não existir, será criado. Se nenhuma variável VarSet foi definida, nenhuma entrada para elas aparecerá no arquivo. Se ocorrer um error ao gravar o arquivo, uma mensagem de evento de erro de script será gerada com o seguinte texto: Failed to save script variables.

Evento do SMS 2003 Monitoring SMS Executive Crash Dump

O script SMS 2003 Monitor SMS Executive Crash Dumps informa por meio do evento 1710 que ocorreu um despejo, como descrito abaixo:

EventType = Erro

EventNumber = 1710

Category = SMS Site Code

Descrição = O SMS Executive no site “XXX” foi paralisado. Para obter detalhes, consulte informações sobre despejo de memória em <Drive> \SMS\Logs\CrashDumps\NewFolder.

Evento de Erro do Script SMS 2003 Monitoring SMS Executive Crash Dumps

O script “SMS 2003 Monitor SMS Executive Crash Dumps” informa erros de script em tempo de execução por meio do evento 1102.

EventType = Aviso

EventNumber = 1102

Descrição = O script “SMS 2003 Monitor SMS Executive Crash Dumps” em execução com a regra de processamento SMS 2003 Crash Dumps: Monitoring SMS Executive encontrou um erro em tempo de execução. CrLf “Failed to <Message>." ErrorString

Script SMS 2003 Server Availability

SMS é um aplicativo empresarial importante para gerenciamento de configuração da área de trabalho. Os clientes precisam acompanhar sua disponibilidade de serviço. O Pacote de Gerenciamento fornece uma amostra do script Microsoft SQL Server™ para computar a disponibilidade do sistema do site do SMS com base em alertas gerados em resposta a um status de desativação do SMS Site System Status Summarizer. A disponibilidade pode ser determinada sobre qualquer número de dias especificados. Essa medida pode ser usada no suporte de SLAs (service level agreements) estabelecidos.

Limitações do Script SMS 2003 Server Availability

O Script SMS 2003 Server Availability tem as seguintes limitações.

Os dados exibidos limitam-se ao intervalo do grooming do banco de dados do Operations Manager 2007. O padrão é o script retornar dados dos últimos sete dias e dos últimos 30 dias. Entretanto, o banco de dados OperationsManager tem um intervalo de grooming de 4 dias, logo, a execução do script com intervalos de sete e 30 dias retorna os mesmos resultados. Se for necessário gerar relatórios que apresentem períodos mais longos, você precisará aumentar o intervalo de grooming ou usar o Relatório SMS 2003 Server Availability que executa junto ao banco de dados OperationsManagerDW, que é o armazenamento de longo prazo para dados operacionais. Para períodos menores, os intervalos de 7 e 30 dias no script precisam ser alterados.

Algoritmo do Script

Uma vez a cada hora, o resumidor do sistema do site tenta fazer contato com cada sistema do site. Se não for possível fazer contato com um sistema do site, esse computador será listado como desativado na tabela do Site System Status Summarizer. Para reduzir o número de falsos relatórios dessa condição, o Pacote de Gerenciamento consolida eventos e gera um alerta somente se houver dois eventos em um período de duas horas. Quando você executa o procedimento armazenado, ele calcula o número de alertas de “Site System is possibly down” que são gerados durante o número especificado de dias, subtrai o tempo de inatividade do tempo total disponível e retorna um percentual de disponibilidade para esse período. Se um computador não registrou o log de nenhum alerta “Site System is possibly down” durante o intervalo especificado, sua disponibilidade calculada é de 100%.

Você não precisa executar o script com mais freqüência do que a cada sete dias, a menos que deseje ver uma tendência diária.

O padrão é o script retornar dados dos últimos sete dias e dos últimos 30 dias. Ao especificar um intervalo de dados mais longo, será fornecida uma estimativa mais acurada do tempo de atividade do servidor. Não defina os intervalos para um período maior que o ciclo de grooming do banco de dados do Operations Manager 2007.

Os exemplos a seguir mostram como a disponibilidade do servidor aumenta quando os dados são calculados pela média de um período maior:

  • Se houver dois eventos gerados para um computador dentro de duas horas, será gerado um alerta. Se um alerta for gerado nos últimos sete dias, os cálculos serão os seguintes:
    • Número total de horas em sete dias = 7 * 24 = 168
    • Número total de horas de inatividade = 1 * 2 = 2
    • Número total de horas de atividade = (168 - 2) = 166
    • Disponibilidade percentual = (166 / 168) * 100 = 98,809%
  • Se um alerta for gerado nos últimos 30 dias, os cálculos serão os seguintes:
    • Número total de horas em 30 dias = 30 * 24 = 720
    • Número total de horas de inatividade = 1 * 2 = 2
    • Número total de horas de atividade = (720 - 2) = 718
    • Disponibilidade percentual = (718 / 720) * 100 = 99,72%
  • Se um alerta for gerado nos últimos 84 dias, os cálculos serão os seguintes:
    • Número total de horas em 84 dias = 84 * 24 = 2016
    • Número total de horas de inatividade = 1 * 2 = 2
    • Número total de horas de atividade = (2016 - 2) = 2014
    • Disponibilidade percentual = (2014 / 2016) * 100 = 99,9%

Os exemplos a seguir mostram como a disponibilidade do servidor muda quando mais alertas são registrados em log no mesmo período:

  • Se dois alertas forem gerados nos últimos 30 dias, os cálculos serão os seguintes:
    • Número total de horas em 30 dias = 30 * 24 = 720
    • Número total de horas de inatividade = 2 * 2 = 4
    • Número total de horas de atividade = (720 - 4) = 716
    • Disponibilidade percentual = (716 / 720) * 100 = 99,44%
  • Se três alertas forem gerados nos últimos 30 dias, os cálculos serão os seguintes:
    • Número total de horas em 30 dias = 30 * 24 = 720
    • Número total de horas de inatividade = 3 * 2 = 6
    • Número total de horas de atividade = (720 - 6) = 714
    • Disponibilidade percentual = (714 / 720) * 100 = 99,16%

O intervalo de pesquisa do Site System Status Summarizer é fixado em uma hora e não pode ser alterado por meio do console do Administrador do SMS. A modificação desse intervalo não melhora a precisão do script. É possível alterar o intervalo de consolidação do evento, mas não é recomendado, porque não melhora a precisão do resultado. De fato, reduzir o intervalo de consolidação torna os resultados menos confiáveis, porque o intervalo de consolidação de duas horas reduz os falsos resultados a uma interrupção momentânea da rede.

Consulte também

Recursos adicionais para o Pacote de Gerenciamento do Microsoft System Management Server 2003
Sites e componentes do Pacote de Gerenciamento do SMS 2003
Grupos de computadores do SMS 2003
Grupo de regras do SMS 2003
Provedores do SMS 2003
Scripts do SMS 2003
Exibições do Microsoft SMS 2003
Diagramas do SMS 2003
Relatórios do SMS 2003


Exibições do Microsoft SMS 2003

O Pacote de Gerenciamento do SMS 2003 fornece os seguintes modos de exibição comuns:

  • Alertas
  • Eventos
  • Diagrama hierárquico do site do SMS 2003
  • Modo de exibição Estado
  • Modo de exibição Status da Tarefa
  • Geral
  • Desempenho

Também são fornecidos os modos de exibição a seguir, personalizados para o SMS 2003:

Diagrama hierárquico do site do SMS 2003

  • Hierarquia do SMS 2003

Geral

  • Alertas do servidor do site central do SMS nas últimas 72 horas
  • Alertas que são novos nas últimas 72 horas

Modos de exibição de Desempenho

É possível configurar os modos de exibição para mostra dados de determinados computadores por exibição. Para fazer isso, é recomendável copiar o modo de exibição que deseja personalizar em Meu Espaço de Trabalho, renomear o modo de exibição e começar a personalizá-lo de acordo com suas necessidades. A complexidade do gráfico pode ser reduzida selecionando individualmente o contador dos computadores pertinentes.

Registros posteriores\Servidores de pontos de gerenciamento

  • Registro posterior do DDR nas últimas 48 horas
  • Registro posterior de coleta de arquivos nas últimas 48 horas
  • Registro posterior do HINV nas últimas 48 horas
  • Registro posterior de retransmissão nas últimas 48 horas
  • Registro posterior do SINV nas últimas 48 horas
  • Registro posterior de status nas últimas 48 horas

Registros posteriores\Servidores do site

  • Registro posterior do DDR nas últimas 48 horas
  • Registro posterior do HINV nas últimas 48 horas
  • Registro posterior dos trabalhos do agendador nas últimas 48 horas
  • Registro posterior das solicitações de envio do agendador nas últimas 48 horas
  • Registro posterior do SINV nas últimas 48 horas
  • Registro posterior do SWM nas últimas 48 horas

Geral\Servidores do ponto de gerenciamento

  • Disco lógico nas últimas 48 horas
  • Memória nas últimas 48 horas
  • Processador nas últimas 48 horas

Geral\Servidores do site

  • Disco lógico nas últimas 48 horas
  • Memória nas últimas 48 horas
  • Processador nas últimas 48 horas
Observação
O provedor de desempenho do modo de exibição Disco lógico nas últimas 48 horas é instalado com o Pacote de Gerenciamento do sistema operacional Microsoft Windows Server básico.

Taxas de processamento

  • *Taxas de processamento de todas as mensagens em um Servidor do ponto de gerenciamento do SMS 2003 nas últimas 24 horas
  • *Taxas de processamento de todos os relatórios em um Servidor do ponto de gerenciamento do SMS 2003 nas últimas 24 horas
  • *Taxas de processamento de todos os relatórios em um Servidor do site do SMS 2003 nas últimas 24 horas

Taxas de processamento\Servidores do ponto de gerenciamento

  • DDRs/seg. nas últimas 24 horas
  • Tentativas de conexão do banco de dados DM/seg. nas últimas 24 horas
  • DDRs DM/seg. nas últimas 24 horas
  • Solicitações de conversão de descoberta DM/seg. nas últimas 24 horas
  • Locais de DP DM/seg. nas últimas 24 horas
  • Solicitações de conversão de inventário de hardware DM/seg. nas últimas 24 horas
  • HINVs DM/seg. nas últimas 24 horas
  • Solicitações do ISAPI DM/seg. nas últimas 24 horas
  • Solicitações de configuração da máquina DM/seg. nas últimas 24 Horas
  • Solicitações de versão do pacote DM/seg. nas últimas 24 horas
  • SINVs DM/seg. nas últimas 24 horas
  • Solicitações de corpo de diretiva de software DM/seg. nas últimas 24 horas
  • Solicitações de identificação de diretiva de software DM/seg. nas últimas 24 horas
  • Status DM/seg. nas últimas 24 horas
  • Solicitações de configuração total DM/seg. nas últimas 24 Horas
  • Locais de DP/seg. nas últimas 24 horas
  • Solicitações de autenticação/seg. nas últimas 24 horas
  • Solicitações de diretiva/seg. nas últimas 24 horas
  • HINVs/seg. nas últimas 24 horas
  • Solicitações do ISAPI/seg. nas últimas 24 horas
  • Locais de MP/seg. nas últimas 24 horas
  • Solicitações de PA/seg. nas últimas 24 horas
  • Relatórios de retransmissão/seg. nas últimas 24 horas
  • SINVs/seg. nas últimas 24 horas
  • SPs executados/seg. nas últimas 24 horas
  • Status/seg. nas últimas 24 horas
  • DDRs totais nas últimas 24 horas
  • DDRs DM totais nas últimas 24 horas
  • HINVs DM totais nas últimas 24 horas
  • Solicitações do ISAPI DM totais distribuídas nas últimas 24 horas
  • Solicitações do ISAPI DM totais recebidas nas últimas 24 horas
  • SINVs DM totais nas últimas 24 horas
  • Status DM total nas últimas 24 horas
  • HINVs totais nas últimas 24 horas
  • Relatórios de retransmissão totais nas últimas 24 horas
  • SINVs totais nas últimas 24 horas
  • Status total nas últimas 24 horas

Taxas de processamento\Servidores do banco de dados do site

  • Conexões do usuário do SQL Server nas últimas 24 horas

Taxas de processamento\Servidores do site

  • DDRs/minuto nas últimas 24 horas
  • HINVs/minuto nas últimas 24 horas
  • SINVs/minuto nas últimas 24 horas
  • Status/minuto nas últimas 24 horas
  • SWMs/minuto nas últimas 24 horas
  • DDRs totais nas últimas 24 horas
  • HINVs totais nas últimas 24 horas
  • SINVs totais nas últimas 24 horas
  • Status total nas últimas 24 horas
  • SWMs totais nas últimas 24 horas

Consulte também

Recursos adicionais para o Pacote de Gerenciamento do Microsoft System Management Server 2003
Sites e componentes do Pacote de Gerenciamento do SMS 2003
Grupos de computadores do SMS 2003
Grupo de regras do SMS 2003
Provedores do SMS 2003
Scripts do SMS 2003
Exibições do Microsoft SMS 2003
Diagramas do SMS 2003
Relatórios do SMS 2003


Diagramas do SMS 2003

O Pacote de Gerenciamento do SMS 2003 fornece um diagrama da topologia da hierarquia do SMS. Os servidores de site e os sistemas de site mostram as respectivas relações um com o outro, incluindo informações contextuais. Os diagramas de topologia incluem dados lógicos, como hierarquias e sites, e dados físicos, como servidores de site e sistemas de site. Como as hierarquias do SMS 2003 podem ser grandes, você pode definir o escopo da exibição da sua hierarquia como qualquer grupo de computadores do SMS 2003 usando o filtro Grupo.

O suporte a diagramas de topologia no Pacote de Gerenciamento do SMS 2003 no Operations Manager 2007 tem os seguintes requisitos:

  • SMS 2003 SP3 instalado nos servidores SMS diagramados
  • Os diagramas de topologia devem estar habilitados
  • Cada função do site deve ser configurada com um nome de domínio totalmente qualificado (FQDN) usando o console do administrador do SMS 2003

Para que a descoberta da topologia produza um diagrama da hierarquia do SMS 2003, os computadores do Provedor do SMS devem ser gerenciados, um agente deve ser instalado nesses computadores e o proxy de agente deve ser habilitado nos outros computadores. Além disso, para que sejam exibidos conectores entre os servidores do site e os sistemas do site, estes últimos devem ter sido descobertos por um processo de descoberta do SMS e devem ser membros da coleção Todos os Sistemas.

A descoberta é realizada em cada site individualmente a partir de sites principais, e os sites secundários são descobertos como parte da descoberta do site principal pai. Os dados sobre a descoberta são fornecidos por meio de dicas de ferramentas e anotações do servidor. Além disso, os diagramas podem ser exportados em um formato de arquivo do Microsoft Visio®.

Anotações de imagem de topologia do servidor do SMS

Ícones dos tipos de servidores

  • Tipo de servidor de banco de dados: Banco de dados do site
  • Tipo de sistema do site: Ponto de gerenciamento
  • Tipo de servidor: Site central, site principal, site secundário e sistema do site

Linhas conectoras

A cor e o estilo da linha conectora denotam o tipo de relacionamento entre dois computadores:

  • O conector de servidor do site a servidor do site é uma linha preta sólida.
  • O conector de servidor do site a sistema do site é uma linha azul pontilhada.

Consulte também

Recursos adicionais para o Pacote de Gerenciamento do Microsoft System Management Server 2003
Sites e componentes do Pacote de Gerenciamento do SMS 2003
Grupos de computadores do SMS 2003
Grupo de regras do SMS 2003
Provedores do SMS 2003
Scripts do SMS 2003
Exibições do Microsoft SMS 2003
Diagramas do SMS 2003
Relatórios do SMS 2003


Relatórios do SMS 2003

Os relatórios descritos nesta seção estão disponíveis no Pacote de Gerenciamento do SMS 2003. Os relatórios são um componente opcional que deve ser instalado separadamente. Para obter mais informações sobre como implantar o servidor de relatórios, consulte a página da Web do produto Operations Manager 2007 (http://go.microsoft.com/fwlink/?LinkID=83259).

Relatórios do SMS

O Pacote de Gerenciamento do Systems Management Server 2003 inclui três tipos de relatórios:

  • Desempenho
  • Configuração
  • Disponibilidade

Os relatórios são destinados a grupos ou objetos pelo uso do seletor de objetos. Todos os relatórios são relatórios vinculados que se beneficiam dos recursos de relatório do Operations Manager 2007. Você pode escolher um dos sete formatos de exportação para gerar seus relatórios.

Relatórios de disponibilidade

Há três relatórios de Disponibilidade no Pacote de Gerenciamento do SMS 2003. Esses relatórios podem ser executados contra o grupo de destino do seletor de objetos Microsoft.SMS.2003.ServersGroup por meio da seleção do Grupo do Servidor SMS (Microsoft.SMS.2003.ServersGroup).

Relatório de disponibilidade do servidor

O relatório de disponibilidade do servidor é baseado no estado de integridade agregado de todas as entidades em um determinado servidor. Este relatório inclui os estados de integridade das funções monitoradas do SMS, bem como os estados de integridade de todas as outras funções monitoradas.

Disponibilidade do servidor do site

O relatório de disponibilidade do servidor do site é baseado no estado de integridade de um servidor do site. Este relatório usa informações do monitor de integridade.

Relatório de disponibilidade de ponto de gerenciamento

O relatório de disponibilidade de ponto de gerenciamento é baseado no estado de integridade de um ponto de gerenciamento. Este relatório usa informações do monitor de integridade.

Relatório de configuração

Há um relatório de configuração disponível no Pacote de Gerenciamento do SMS 2003, o relatório de configuração de cliente do servidor SMS 2003. Este é um relatório de configuração personalizado básico que contém as propriedades de um servidor SMS ou um grupo de servidores SMS.

O relatório exibe as seguintes propriedades do SMS:

  • Versão (versão do produto SMS)
  • Tipo de sistema do site (tipo de sistema do site, tipo de servidor, tipo de servidor de banco de dados)
  • Componentes (servidor do site, ponto localizador de servidor, ponto de distribuição, ponto de gerenciamento, ponto de relatório, servidor de banco de dados, provedor, remetente, ponto de acesso do cliente)
  • Código do site (código do site SMS)
  • Tipo de servidor (servidor de site central, principal ou secundário)
  • Nome (nome NetBIOS)
  • Tipo de servidor de banco de dados (servidor de banco de dados do site)

Este relatório pode ser executado contra o grupo de destino do seletor de objetos Microsoft.SMS.2003.ServersGroup.

Desempenho

Os relatórios de desempenho foram agrupados em unidades com base, primeiramente, na função do site monitorada e, em seguida, por contadores se forem contadores de desempenho relacionados à taxa (por exemplo, por segundo ou por minuto) ou contadores de dados brutos (totais). Esse agrupamento garante que todos os contadores de um relatório usam uma escala semelhante.

Os relatórios foram desenvolvidos com base no tipo de análise solicitada. Dois conjuntos de relatórios estão disponíveis, dependendo do tipo de análise solicitada. Um conjunto mostra todos os contadores de desempenho para uma determinada função do servidor SMS, por exemplo, um ponto de gerenciamento ou um servidor do site. O segundo conjunto mostra todos os contadores para um determinado objeto de processamento, por exemplo, inventário de hardware, para todas as funções do site.

Relatórios de grupo de desempenho do servidor SMS 2003

Para executar os relatórios a seguir, selecione Microsoft.SMS.2003.ServerPerformanceGroup no grupo de destino do seletor de objetos.

Desempenho bruto do Registro de Descoberta de Dados (DDR) do SMS 2003

Este relatório exibe os totais e os registros posteriores do registro de descoberta de dados (DDR) processados para todas as funções do servidor SMS aplicáveis.

Medida de desempenho do SMS 2003: Registro posterior do DDR do servidor do site | Total de DDRs em fila
Medida de desempenho do SMS 2003: Total de DDRs do servidor do site processados | Total de DDRs processados
Medida de desempenho do SMS 2003: Registro posterior de DDR do MP | Mensagens em fila
Medida de desempenho do SMS 2003: Gerenciador de DDR do MP (total de relatórios) | Total de relatórios
Medida de desempenho do SMS 2003: Total de DDRs processados do DMP | Total de relatórios de descoberta gerados

Desempenho de taxa do Registro de Descoberta de Dados (DDR) do SMS 2003

Este relatório exibe as taxas de processamento do registro de descoberta de dados (DDR) para todas as funções do servidor SMS aplicáveis.

Medida de desempenho do SMS 2003: Taxa de processamento do DDR do servidor do site | DDRs processados/minuto
Medida de desempenho do SMS 2003: Gerenciador de DDR do MP (total de relatórios/segundo) | Total de relatórios/segundo
Medida de desempenho do SMS 2003: Taxa de processamento de DDR do DMP | Relatórios de descoberta gerados/segundo

Desempenho bruto do inventário de hardware (HINV) do SMS 2003

Este relatório exibe os totais e os registros posteriores do inventário de hardware (HINV) processados para todas as funções do servidor SMS aplicáveis.

Medida de desempenho do SMS 2003: Registro posterior do HINV do servidor do site | Total de MIFs em fila
Medida de desempenho do SMS 2003: Total de HINVs do servidor do site processados | Total de MIFs processados
Medida de desempenho do SMS 2003: Registro posterior de HINV do MP | Mensagens em fila
Medida de desempenho do SMS 2003: Gerenciador de HINV do MP (total de relatórios) | Total de relatórios
Medida de desempenho do SMS 2003: Total de HINVs processados do DMP | Total de relatórios de inventário de hardware gerados

Desempenho de taxa do inventário de hardware (HINV) do SMS 2003

Este relatório exibe as taxas de processamento do inventário de hardware (HINV) para todas as funções do servidor SMS aplicáveis.

Medida de desempenho do SMS 2003: Taxa de processamento do HINV do servidor do site | MIFs processados/minuto
Medida de desempenho do SMS 2003: Gerenciador de HINV do MP (total de relatórios/segundo) | Total de relatórios/segundo
Medida de desempenho do SMS 2003: Gerenciador de repetições do HINV do MP (total de relatórios/segundo) | Total de relatórios/segundo
Medida de desempenho do SMS 2003: Taxa de processamento de HINV do DMP | Relatórios de inventário de hardware gerados/segundo

Desempenho bruto do inventário de software (SINV) do SMS 2003

Este relatório exibe os totais e os registros posteriores do inventário de software (SINV) processados para todas as funções do servidor SMS aplicáveis.

Medida de desempenho do SMS 2003: Registro posterior do SINV do servidor do site | Total de SINVs em fila
Medida de desempenho do SMS 2003: Total de SINVs do servidor do site processados | Total de SINVs processados
Medida de desempenho do SMS 2003: Registro posterior de coleta de arquivos do MP | Mensagens em fila
Medida de desempenho do SMS 2003: Registro posterior de SINV do MP | Mensagens em fila
Medida de desempenho do SMS 2003: Gerenciador de SINV do MP (total de relatórios) | Total de relatórios
Medida de desempenho do SMS 2003: Total de SINVs processados do DMP | Total de relatórios de inventário de software gerados

Desempenho de taxa do inventário de software (SINV) do SMS 2003

Este relatório exibe as taxas de processamento do inventário de software (SINV) para todas as funções do servidor SMS aplicáveis.

Medida de desempenho do SMS 2003: Taxa de processamento do SINV do servidor do site | SINVs processados/minuto
Medida de desempenho do SMS 2003: Gerenciador de SINV do MP (total de relatórios/segundo) | Total de relatórios/segundo
Medida de desempenho do SMS 2003: Gerenciador de ColFile do MP (total de relatórios/segundo) | Total de relatórios/segundo
Medida de desempenho do SMS 2003: Taxa de processamento de SINV do DMP | Relatórios de inventário de software gerados/segundo

Desempenho de recursos do sistema do servidor SMS 2003

Este relatório exibe o uso de recursos do sistema pelas funções do servidor SMS.

Medida de desempenho do SMS 2003: Memória - %Bytes comprometidos em uso | Bytes comprometidos em uso
Medida de desempenho do SMS 2003: Arquivo de paginação - Porcentagem de uso | Porcentagem de uso
Medida de desempenho do SMS 2003: Processador - Porcentagem de tempo do processador (_Total) | Porcentagem de tempo do processador
Medida de desempenho do SMS 2003: Processo - Porcentagem de tempo do processador (smsexec) | Porcentagem de tempo do processador
Medida de desempenho do SMS 2003: Processo - Porcentagem de tempo do processador (ccmexec) | Porcentagem de tempo do processador
Medida de desempenho do SMS 2003: Sistema - Tempo de funcionamento do sistema | Tempo de funcionamento do sistema

Desempenho bruto da medição de software (SWM) do SMS 2003

Este relatório exibe os totais e os registros posteriores da medição de software (SWM) processados para todas as funções do servidor SMS aplicáveis.

Medida de desempenho do SMS 2003: Registro posterior do SWM do servidor do site | Total de arquivos de uso de SWM em fila
Medida de desempenho do SMS 2003: Total de SWMs do servidor do site processados | Total de registros de uso de SWM processados
Medida de desempenho do SMS 2003: Registro posterior do gerenciador de relé do MP | Mensagens em fila
Medida de desempenho do SMS 2003: Gerenciador de relé do MP (total de relatórios) | Total de relatórios

Desempenho de taxa da medição de software (SWM) do SMS 2003

Este relatório exibe as taxas de processamento da medição de software (SWM) para todas as funções do servidor SMS aplicáveis.

Medida de desempenho do SMS 2003: Taxa de processamento do SWM do servidor do site | Registros de uso de SWM processados/minuto
Medida de desempenho do SMS 2003: Gerenciador de relé do MP (total de relatórios/segundo) | Total de relatórios/segundo

Desempenho bruto das mensagens de status do SMS 2003

Este relatório exibe os totais e os registros posteriores das mensagens de status do SMS processadas para todas as funções do servidor SMS aplicáveis.

Medida de desempenho do SMS 2003: Total de mensagens de status do servidor do site processadas | Recebidas
Medida de desempenho do SMS 2003: Registro posterior de status do MP | Mensagens em fila
Medida de desempenho do SMS 2003: Gerenciador de status do MP (total de eventos) | Total de eventos
Medida de desempenho do SMS 2003: Total de mensagens de status do DMP processadas | Total de mensagens de status geradas

Desempenho de taxa das mensagens de status do SMS 2003

Este relatório exibe as taxas de processamento das mensagens de status do SMS para todas as funções do servidor SMS aplicáveis.

Medida de desempenho do SMS 2003: Taxa de processamento de status do servidor do site | Processado/segundo
Medida de desempenho do SMS 2003: Gerenciador de status do MP (total de eventos/segundo) | Total de eventos/segundo
Medida de desempenho do SMS 2003: Taxa de processamento de status do DMP | Mensagens de status geradas/segundo

Desempenho das funções do servidor de suporte do SMS 2003

Este relatório exibe o desempenho dos serviços que suportam as funções do servidor SMS.

Medida de desempenho do SMS 2003: Serviço Web (solicitações de extensão ISAPI/segundo) | Solicitações de extensão ISAPI/segundo
Medida de desempenho do SMS 2003: Conexões SQL do SMS | Conexões de usuário

Relatórios do servidor de ponto de gerenciamento do SMS 2003

Para executar os relatórios a seguir, selecione Servidores de Ponto de Gerenciamento Microsoft no grupo de destino do seletor de objetos.

Desempenho bruto do ponto de gerenciamento de dispositivo do SMS 2003

Este exibe os totais processados para a função do servidor Ponto de Gerenciamento de Dispositivo do SMS.

Medida de desempenho do SMS 2003: Total de DDRs processados do DMP | Total de relatórios de descoberta gerados
Medida de desempenho do SMS 2003: Total de HINVs processados do DMP | Total de relatórios de inventário de hardware gerados
Medida de desempenho do SMS 2003: Total de SINVs processados do DMP | Total de relatórios de inventário de software gerados
Medida de desempenho do SMS 2003: Total de mensagens de status do DMP processadas | Total de mensagens de status geradas
Medida de desempenho do SMS 2003: Total de solicitações ISAPI do DMP distribuídas | Total de mensagens distribuídas
Medida de desempenho do SMS 2003: Total de solicitações ISAPI do DMP recebidas | Total de mensagens recebidas

Desempenho de taxa do ponto de gerenciamento de dispositivo do SMS 2003

Este relatório exibe as taxas de processamento da função do servidor Ponto de Gerenciamento de Dispositivo do SMS.

Medida de desempenho do SMS 2003: Taxa de solicitação de configuração do DMP | Solicitações de configuração do DMP/segundo
Medida de desempenho do SMS 2003: Taxa de solicitação de configuração de máquina DMP | Solicitações de configuração de máquina/segundo
Medida de desempenho do SMS 2003: Taxa de solicitações de ID de diretiva de software do DMP | Solicitações de ID de diretiva de software/segundo
Medida de desempenho do SMS 2003: Taxa de solicitações de corpo de diretiva de software do DMP | Solicitações de corpo de diretiva de software/segundo
Medida de desempenho do SMS 2003: Taxa de solicitações de versão do pacote do DMP | Solicitações de versão do pacote/segundo
Medida de desempenho do SMS 2003: Taxa de solicitações de conversão de descoberta do DMP | Solicitações de conversão de descoberta/segundo
Medida de desempenho do SMS 2003: Taxa de solicitação de conversão de inventário de hardware do DMP | Solicitações de conversão do inventário de hardware/segundo
Medida de desempenho do SMS 2003: Taxa de tentativas de conexão do banco de dados do DMP | Tentativas de conexão do banco de dados/segundo
Medida de desempenho do SMS 2003: Taxa de processamento de DDR do DMP | Relatórios de descoberta gerados/segundo
Medida de desempenho do SMS 2003: Taxa de processamento de HINV do DMP | Relatórios de inventário de hardware gerados/segundo
Medida de desempenho do SMS 2003: Taxa de processamento de solicitações de local de DP do DMP | Solicitações de local geradas/segundo
Medida de desempenho do SMS 2003: Taxa de processamento das mensagens ISAPI do DMP | Mensagens distribuídas/segundo
Medida de desempenho do SMS 2003: Taxa de processamento de SINV do DMP | Relatórios de inventário de software gerados/segundo
Medida de desempenho do SMS 2003: Taxa de processamento de status do DMP | Mensagens de status geradas/segundo

Desempenho bruto do ponto de gerenciamento do SMS 2003

Este relatório exibe os registros posteriores e os totais processados para a função de servidor Ponto de Gerenciamento do SMS.

Medida de desempenho do SMS 2003: Registro posterior de DDR do MP | Mensagens em fila
Medida de desempenho do SMS 2003: Gerenciador de DDR do MP (total de relatórios) | Total de relatórios
Medida de desempenho do SMS 2003: Registro posterior de HINV do MP | Mensagens em fila
Medida de desempenho do SMS 2003: Gerenciador de HINV do MP (total de relatórios) | Total de relatórios
Medida de desempenho do SMS 2003: Registro posterior de coleta de arquivos do MP | Mensagens em fila
Medida de desempenho do SMS 2003: Registro posterior de SINV do MP | Mensagens em fila
Medida de desempenho do SMS 2003: Gerenciador de SINV do MP (total de relatórios) | Total de relatórios
Medida de desempenho do SMS 2003: Registro posterior do gerenciador de relé do MP | Mensagens em fila
Medida de desempenho do SMS 2003: Gerenciador de relé do MP (total de relatórios) | Total de relatórios
Medida de desempenho do SMS 2003: Registro posterior de status do MP | Mensagens em fila
Medida de desempenho do SMS 2003: Gerenciador de status do MP (total de eventos) | Total de eventos

Desempenho de taxa do ponto de gerenciamento do SMS 2003

Este relatório exibe as taxas de processamento da função do servidor Ponto de Gerenciamento do SMS.

Medida de desempenho do SMS 2003: Gerenciador de local do MP (solicitações do MP/segundo) | Solicitações do MP/segundo
Medida de desempenho do SMS 2003: Gerenciador de local do MP (solicitações do DP/segundo) | Solicitações do DP/segundo
Medida de desempenho do SMS 2003: Diretiva MP Get (solicitações/segundo) | Solicitações/segundo
Medida de desempenho do SMS 2003: Autorização MP Get (solicitações/segundo) | Solicitações/segundo
Medida de desempenho do SMS 2003: Gerenciador de diretiva do MP (solicitações de PA/segundo) | Solicitações de PA/segundo
Medida de desempenho do SMS 2003: DAL do MP (SPs executados/segundo) | SPs executados/segundo
Medida de desempenho do SMS 2003: Gerenciador de HINV do MP (total de relatórios/segundo) | Total de relatórios/segundo
Medida de desempenho do SMS 2003: Gerenciador de repetições do HINV do MP (total de relatórios/segundo) | Total de relatórios/segundo
Medida de desempenho do SMS 2003: Gerenciador de SINV do MP (total de relatórios/segundo) | Total de relatórios/segundo
Medida de desempenho do SMS 2003: Gerenciador de ColFile do MP (total de relatórios/segundo) | Total de relatórios/segundo
Medida de desempenho do SMS 2003: Gerenciador de relé do MP (total de relatórios/segundo) | Total de relatórios/segundo
Medida de desempenho do SMS 2003: Gerenciador de status do MP (total de eventos/segundo) | Total de eventos/segundo

Consulte também

Recursos adicionais para o Pacote de Gerenciamento do Microsoft System Management Server 2003
Sites e componentes do Pacote de Gerenciamento do SMS 2003
Grupos de computadores do SMS 2003
Grupo de regras do SMS 2003
Provedores do SMS 2003
Scripts do SMS 2003
Exibições do Microsoft SMS 2003
Diagramas do SMS 2003
Relatórios do SMS 2003